XL 2016 Formule Matricielle pour trier les élèves d'un même niveau uniquement

arn@

XLDnaute Nouveau
Bonjour
Je souhaiterais après avoir récupérer les résultats d'une course, classer les élèves par niveau (6ème et 5ème) j’essaie d'utiliser une formule matricielle que j'utilise dans d'autre fichier mais cela ne marche pas, est ce que quelqu'un peux m'aider svp?
Voici ma formule:
=SI(LIGNES($1:1)<=NB.SI($U$4:$U$2000;$AC$1);INDEX($V$4:$V$2000;PETITE.VALEUR(SI($U$4:$U$2000=$AC$1;LIGNE(INDIRECT("1:"&LIGNES($U$4:$U$2000))));LIGNES(1:1)));"")

$U$4:$U$2000 = Colonne avec valeur 5 ou 6
$V$4:$V$2000 = Colonne avec valeur du Dossard
$AC$1 = Valeur 5

Dans le fichier joint cela se passe dans la feuille "Classement Total" au niveau de la colonne AD
(Je suis sous excel 2016)
 

Fichiers joints

djidji59430

XLDnaute Accro
Bonjour,
les valeurs de ta colonne U sont textuelles. Pour les faire passer en nombre, utilise
=SI(V4>10;GAUCHE(DROITE(V4;4);1)*1;"")

Crdmt
 

Discussions similaires


Haut Bas