Microsoft 365 Formule GAUCHE imbriquée dans RECHERCHEV

Coralie01120

XLDnaute Occasionnel
Bonjour Le Forum,

J'ai regardé sur les fils de discussions mais même en testant les solutions proposées je ne retrouve pas mon bonheur.
Je cherche à utiliser une RECHERCHEV avec une formule GAUCHE imbriquée, ce qui parait simple mais la formule ne fonctionne pas chez moi.

Je souhaite remplir la colonne C de l'onglet Suivi prod avec comme critère de recherche ma colonne B qui vient récupérer les données de la colonne C de l'onglet Planning.

Je ne sais pas si c'est un problème de format ou autre mais je ne trouve pas.

Ci-joint le fichier.

Je vous remercie pour votre aide.
 

Pièces jointes

  • Suivi Production.xls
    199 KB · Affichages: 7
Solution
Bonjour à tous,
Bonjour Jocelyn :)

La fonction gauche te donne un résultat en format texte donc si tu fais une recherche sur des chiffres cela ne fonctionnera pas.
A essayer
VB:
=SIERREUR(RECHERCHEV(SI(ESTNUM(B5);B5;GAUCHE(B5;NBCAR(B5)-1)*1);Planning!$B$2:$C$239;2;FAUX);"inconnu")

JHA

JHA

XLDnaute Barbatruc
Bonjour à tous,
Bonjour Jocelyn :)

La fonction gauche te donne un résultat en format texte donc si tu fais une recherche sur des chiffres cela ne fonctionnera pas.
A essayer
VB:
=SIERREUR(RECHERCHEV(SI(ESTNUM(B5);B5;GAUCHE(B5;NBCAR(B5)-1)*1);Planning!$B$2:$C$239;2;FAUX);"inconnu")

JHA
 

Statistiques des forums

Discussions
288 693
Messages
1 894 017
Membres
170 246
dernier inscrit
Fahdj2002
Haut Bas