[Formule] Extraction de données sous condition de dates

Efgé

XLDnaute Barbatruc
Bonjour à toutes, tous, le forum
Décidément, les matricielles et moi on ne s'entend pas....
Comment extraire des initiales présentent dans un tableau suivant une année saisie?
J'ai une liste de noms ,prénoms, initiales, date d'entrée, date de sortie.
Comment extraire les initiales des personnes présentent suivant une année donnée?

Un petit exemple en pièce jointe ne sera pas superflu :)

A votre bon cœur m'sieurs dames.

Cordialement
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
Re : [Formule] Extraction de données sous condition de dates

Bonjour le Forum,
Bonjour l'ami Efgé :),

Peut être comme cela :), au fait pas besoin des données de la plage F2:G5 :eek:

Amicalement
 

Fichiers joints

Modeste

XLDnaute Barbatruc
Re : [Formule] Extraction de données sous condition de dates

Salut Fred,

Si j'ai compris, en E11, peut-être
Code:
=SIERREUR(INDEX(Tableau6[[Initiales]:[Initiales]];PETITE.VALEUR(SI(Tableau6[[Année_Entrée]:[Année_Entrée]]=$F$9;LIGNE(Tableau6[[Année_Entrée]:[Année_Entrée]])-1);COLONNES($A:A)));"")
Arfff, re-salut Jocelyn
 

Efgé

XLDnaute Barbatruc
Re : [Formule] Extraction de données sous condition de dates

Re

Bonjour Jocelyn :)
Que ferais-je sans tes formules (que dois bien recvonnaitre autant magiques que d'une redoutable efficaccité ) :)
Grand Merci à toi en ce début de semaine pluvieux.
P.S Pour les colonnes F et G je pensai façilité les choses....
Encore Merci.
Cordialement

EDIT
Bonjour Modeste, je vois que tu es toujours là aussi :)
Merci, je vais regarder ça avec intérêt :)

Cordialement
 

job75

XLDnaute Barbatruc
Re : [Formule] Extraction de données sous condition de dates

Bonjour Efgé,

Formule matricielle en E11 du fichier joint :

Code:
=SIERREUR(INDEX(Initiales;PETITE.VALEUR(SI(($F9>=An_Entree)*($F9<=SI(ESTNUM(An_Sortie);An_Sortie;9999));LIGNE(An_Entree)-1);COLONNES($E11:E11)));"")
Edit : salut Jocelyn, Modeste, à la bourre moi.

Bonne journée.
 

Fichiers joints

Efgé

XLDnaute Barbatruc
Re : [Formule] Extraction de données sous condition de dates

Re
Bonjour Job :)
Merci à toi aussi, de te pencher sur mon cas.
Il me reste à décortiquer tout ça...
Cordialement
 

Discussions similaires


Haut Bas