Formule excel a convertir en VBA

ticlaou

XLDnaute Nouveau
Bonjour,

je voudrais convertir cette formule (=SI((B10+B13+B22)=0;"0 Stock";"") en VBA, mais il me sort erreur d'exécution 1004
voici ce que j'ai écrit :
ActiveCell.FormulaLocal = "=(SI(" & "B10" & "+" & "B13" & "+" & "B22" & "=0;" & "0 Stock" & ";" & "" & "))"

Merci pour l'aide.
 

Jacky67

XLDnaute Accro
Bonjour,

je voudrais convertir cette formule (=SI((B10+B13+B22)=0;"0 Stock";"") en VBA, mais il me sort erreur d'exécution 1004
voici ce que j'ai écrit :
ActiveCell.FormulaLocal = "=(SI(" & "B10" & "+" & "B13" & "+" & "B22" & "=0;" & "0 Stock" & ";" & "" & "))"

Merci pour l'aide.
Bonjour,
Essaye comme ceci:
VB:
ActiveCell.Formula = "=IF(b10+b13+b22=0,""0 Stock"","""")"
 

Discussions similaires


Haut Bas