XL pour MAC Formule Cherche avec Si Ou intégré.

Umbro1976

XLDnaute Nouveau
Bonjour à tous,
Je m'appelle Alex et j'ai 35 ans (je bosse dans l'analytique marketing)... J'essaie depuis hier de créer une formule SI(ESTERREUR(CHERCHE en intégrant un "OU".
Je m'explique dans un document Google, il y a une colonne qui intègre une notion pays (ES, IT, FR etc etc). Ce code est noyé dans la cellule et n'est jamais positionné à la même place ce qui m'empeche de faire une formule Droite / Gauche par exemple.
Exemple :
Cellule Colonne C sur mon sheet :
[ES] The Elder Scrolls - Skyrim Leg. Edition (correspond à la cellule C4)
SN - [IT] - Brand IG (correspond à la cellule C5)
PLA - [FR] - Acquisition (correspond à la cellule C6)

J'ai besoin de ce code pays pour ensuite faire un TCD etc.
J'ai commencé ma formule en faisant cela => =SI(ESTERREUR(CHERCHE("*[IT]*";$C$4));"Not Italy";"Italy") mais comment intégrer une formule ou me permettant de lui dire : "si tu ne trouves pas IT alors cherche ES puis FR etc etc etc ???

Merci à tous !
 

job75

XLDnaute Barbatruc
Bonjour Umbro1976, bienvenue sur XLD,

Entrez en D4 cette formule, à tirer vers le bas :
Code:
=STXT(C4;TROUVE("[";C4)+1;TROUVE("]";C4)-TROUVE("[";C4)-1)
ou pour éviter les valeurs d'erreur, si SIERREUR fonctionne :
Code:
=SIERREUR(STXT(C4;TROUVE("[";C4)+1;TROUVE("]";C4)-TROUVE("[";C4)-1);"")
A+
 

job75

XLDnaute Barbatruc
Sélectionner la zone à traiter puis touches Ctrl+H => Rechercher : [*] - Remplacer par : [XX]
 

Discussions similaires


Haut Bas