XL 2010 Formule Calcul Date livraison

Franck74

XLDnaute Nouveau
Bonjour,

Petite question toute bête, je cherche une formule de calcul de date de début selon une date de réception.
J'ai un client qui m'envoie son bon de commande. A réception de celui-ci je dois être en mesure de prévoir la livraison au 01er du mois suivant.
J'ai donc aujourd'hui la formule

Code:
=SI(A1=0;"";MOIS.DECALER(A1;1))
C'est un bon début mais ce n'est pas exactement cela, puisque si je le reçois le 20/09/2019, je dois livrer au 01er octobre 2019 et non au 20.
Est-ce possible avec une formule ou faut-il aller vers du VBA?

En vous remerciant.
 

Jacky67

XLDnaute Accro
Bonjour,

Petite question toute bête, je cherche une formule de calcul de date de début selon une date de réception.
J'ai un client qui m'envoie son bon de commande. A réception de celui-ci je dois être en mesure de prévoir la livraison au 01er du mois suivant.
J'ai donc aujourd'hui la formule

Code:
=SI(A1=0;"";MOIS.DECALER(A1;1))
C'est un bon début mais ce n'est pas exactement cela, puisque si je le reçois le 20/09/2019, je dois livrer au 01er octobre 2019 et non au 20.
Est-ce possible avec une formule ou faut-il aller vers du VBA?

En vous remerciant.
Bonjour,
Essaye
=DATE(ANNEE(A1);MOIS(A1)+1;1)
 

Discussions similaires


Haut Bas