XL 2016 Formule alerte date

ccilette

XLDnaute Nouveau
Bonjour à tous,

j'utilise dans un de mes fichiers cette formule: =SI(MOIS($B$1)=MOIS($F4);"A CONVOQUER";"") avec en B1 la date du jour. J'aimerai que cette formule m'alerte d'un A CONVOQUER 1 mois avant la date indiquée en F4, mais je n'y arrive pas,

pouvez vous m'éclairer de vos lumières?


merci :)
 

Efgé

XLDnaute Barbatruc
Bonjour ccilette
Peut-être:
VB:
=SI(B1>=MOIS.DECALER(F4;-1);"A Convoquer";"")
Cordialement
 

pierrejean

XLDnaute Barbatruc
Bonjour Ccilette
A tester
=SI(B1-F4<30;"A CONVOQUER";"")
Les mois sont tous assimilés à 30 jours
Si plus de précision demandée reviens

Edit salut efge Frangy
 

ccilette

XLDnaute Nouveau
merci a vous deux, les deux formules fonctionnent mais si F4 est vide alors j'ai un #NOMBRE qui apparaît, peut on le faire disparaître?
 

pierrejean

XLDnaute Barbatruc
RE

=SI(F4<>"";SI(B1-F4<30;"A CONVOQUER";"");"")
Le décalage sera de 1 jour la plupart du temps sauf en février ou il pourra être de 3 jours max (année bissextile)
je regarde pour une formule précise
 
Dernière édition:

frangy

XLDnaute Occasionnel
Bonjour à tous,

Tant qu'on y est :
=SIERREUR(SI(DATEDIF($B$1;$F4;"m")<1;"A CONVOQUER";"");"")

Cordialement.
 

frangy

XLDnaute Occasionnel
Bonjour,

Avec la formule
=SIERREUR(SI(DATEDIF($B$1;$F4;"m")<1;"A CONVOQUER";"");"")
tu as l'alerte pour les dates comprises entre le 12/07/2019 et le 11/08/2019, soit 1 mois avant la visite.
Qu'est-ce qui ne marche pas ?

Cordialement.
 

Discussions similaires


Haut Bas