XL 2013 Format de date Anglais/Français

Marc-André

XLDnaute Nouveau
Bonjour,

Mon problème est assez particulier. J'ai un script qui doit lire une date sous le format aaaa-mm-jj et l'écrire. Voici la cellule problématique.
=TEXTE($C$9;"j/m/aa")


J'ai deux ordinateurs. Chacun des ordinateurs utilise les paramètres de région par défaut : Français (Canada).
Sur le premier ordinateur, il n'y a aucun problème avec mon script.
Sur le second, l'ordinateur ne comprends pas ce format et voudrais que j'utilise le format dd-mm-yyyy (nomenclature anglophone pour les format de date).

Afin de régler mon problème, j'ai modifier le second ordinateur en Français (France) mais ça insère des problème avec d'autre logiciel sur la lecture de la date et l'heure. Je suis aussi capable de règler mon problème en changeant le contenu de la cellule qui fait la lecture avec les fonction DATE ou JOUR, MOIS, ANNEE.

Je ne m'explique par contre pas pourquoi ce poste de travail lit le format date en anglais alors qu'il devrait les lire en français. Avez-vous déjà eu un problème semblable?

Merci
 

Modeste geedee

XLDnaute Barbatruc
Bonsour®
J'ai lu quelques part que je pourrais peut-être forcer la nomenclature française à l'aide d'un code entre crochet à l'intérieur de mes apostrophes?
d'où viennent les données ??? (d'un fichier texte, d'une liaison Web, d'un fichier Excel )
selon le cas il faut adapter la méthode à ce qui est lu par rapport à langue du poste lecteur...
3 méthodes différentes...
un exemple (physique pas une image) des données lues avant toute autre intervention, permettrai d'orienter les réponses.
 

Marc-André

XLDnaute Nouveau
Voici l'information, je ne croyais pas utile de le soumettre comme tout fonctionne sur un ordinateur et pas l'autres. Je veux insister que je pourrais changer ces formules et régler ma problématique mais je cherche plutôt à comprendre pourquoi j'ai cette problématique. Les deux lecteurs sont supposément dans la même langue si la seule référence Excel est le paramètre "Région et langue" de Windows 7

L'information provient d'un fichier .txt. Elle est importé dans un fichier Excel-type à l'aide d'une macro VBA. La cellule source est sous format standard et titre :

"2016-07-05 AL=38 SI=1,35 C2= -- PO=0,26 LogC=5,0 LogG=050 DEB1=060 DEB2=060 AL=40 SI=1,65 C2= -- PO=0,30 LogC=4,0 LogG=017 DEB1= -- DEB2= -- AL=44 SI=1,50 C2= -- PO=0,07 LogC=5,4 LogG=050 DEB1=051 DEB2=051 "

J'extrait l'information de cette cellule au moyen de la fonction :
"=STXT($C$6;1;10)"

Puis, j'ai la formule déjà cité :
"=TEXTE($C$9;"j/m/aa")"
 

Modeste geedee

XLDnaute Barbatruc
Bonsour®
Voici l'information, je ne croyais pas utile de le soumettre comme tout fonctionne sur un ordinateur et pas l'autres. Je veux insister que je pourrais changer ces formules et régler ma problématique mais je cherche plutôt à comprendre pourquoi j'ai cette problématique. Les deux lecteurs sont supposément dans la même langue si la seule référence Excel est le paramètre "Région et langue" de Windows 7

L'information provient d'un fichier .txt.
:(:mad:
un extrait de fichier ???
une macro VBA ???

je cherche plutôt à comprendre
voir macro du coté de l'assistant d'importation en précisant l'argument Local:=True
 

Marc-André

XLDnaute Nouveau
Il s'agissait effectivement d'un problème Windows. Si quelqu'un est intéressé, voici la réelle solution meilleur que d'utiliser la configuration Français(France) et modifier les paramètres pour travailler en Français (Canada)

Merci pour cette information. Pour la version Windows 7, Microsoft
a publié un correctif : http://support.microsoft.com/kb/2919469

Cela s'applique au résident de langue anglaise au Canada en particulier ou qui utilise ce pays dans la configuration de langue du panneau de configuration deWindows.


Pour corriger la situation pour les usagers francophones qui ont choisi la langue "Canada Français", on fait comme ceci :


S'applique à Windows 7, 8, 8.1

A ) Fermer toutes les instances d'Excel.
B ) Ouvrir la fenêtre Exécuter : Raccourci clavier : Win + R
C ) Taper la commande : Regedit
D ) Ouvrir l'arborescence comme ceci : HKEY_CURRENT_USER\Control Panel\International
E ) Modifier la valeur de la clé "iCountry" pour la valeur 2
F ) On ferme le tout et c'est réglé.
 

Statistiques des forums

Discussions
292 982
Messages
1 927 690
Membres
183 587
dernier inscrit
loulou1338