Fonction SOMMEPROD qui ne fonctionne pas

Enduristik71

XLDnaute Nouveau
Bonjour à tous,

Je cherche à faire la somme des produits "colonne N" * "colonne O" lorsque la colonne M contient "TOLE".
Pour cela, j'utilise la fonction SOMMEPROD.
Je ne pense pas me tromper, mais la formule me retourne #VALEUR! (alors que dans mon cas, il faudrait qu'elle me retourne 56,37 ...)



Avez-vous déjà eu ce problème ? Si quelqu'un sait d'où vient le problème, je serais ravi qu'il me vienne en aide ;)

Merci par avance,
Cordialement
 

vgendron

XLDnaute Barbatruc
Bonjour à tous,

Je cherche à faire la somme des produits "colonne N" * "colonne O" lorsque la colonne M contient "TOLE".
Pour cela, j'utilise la fonction SOMMEPROD.
Je ne pense pas me tromper, mais la formule me retourne #VALEUR! (alors que dans mon cas, il faudrait qu'elle me retourne 56,37 ...)



Avez-vous déjà eu ce problème ? Si quelqu'un sait d'où vient le problème, je serais ravi qu'il me vienne en aide ;)

Merci par avance,
Cordialement
Bonjour

à la place des x pour les couts matières d'ensemble et sous ensemble, mets 0
ou alors, ajoute une condition (estnum(O5:O19))
 

Amilo

XLDnaute Accro
Bonsoir vgendron, Enduristik71,
Peut-être avec cette formule
Code:
=SOMMEPROD((M5:M19="TOLE")*(N5:N19)*(ESTNUM(O5:O19));O5:O19)
Cordialement
 

Enduristik71

XLDnaute Nouveau
Bonsoir Vgendron, Amilo,

Merci pour votre aide, ça m'a bien aidé.
J'aurais dû penser à remplacer les "x" par des "0". Je devais pas être réveillé !
Par contre, je ne connaissais pas avec la condition utilisant ESTNUM. Pratique !

Merci encore et bonne soirée à vous :)
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas