Fonction « SOMME.SI.ENS » avec liste de critères dynamique/variable

Sghaier Chafaa

XLDnaute Nouveau
Bonjour à vous tous

J’essaye de sommer avec la fonction ‘SOMME.SI.ENS’ une liste ayant multiple critères
La question c’est que le nbr des critères est variable,
Je vise avoir une formule de somme.si.ens dynamique pour une colonne de critère variable ( j’ai essayé même convertir en tableau pour ajout automatique à la liste des critère mais sans résultat
Ma formule , statique, actuelle qui fonctionne est :
=SOMME(SOMME.SI.ENS(B2:B26;A2:A26;F5);SOMME.SI.ENS(B2:B26;A2:A26;F6);SOMME.SI.ENS(B2:B26;A2:A26;F7);SOMME.SI.ENS(B2:B26;A2:A26;F8);SOMME.SI.ENS(B2:B26;A2:A26;F9);SOMME.SI.ENS(B2:B26;A2:A26;F10))

J’ai essayé sans résultat avec :
  • =SOMME(SOMME.SI.ENS(B2:B26;A2:A26;F5;A2:A26;Tableau2[Colonne1]))
  • =SOMME(SOMME.SI.ENS(B2:B26;A2:A26;F5;A2:A26;OU(F5;F6;F7;F8;F9;F10)))
  • =SOMME(SOMME.SI.ENS(B2:B26;A2:A26;F5;A2:A26;F6;A2:A26;F7;A2:A26;F8;A2:A26;F9;A2:A26;F10))
  • {=SOMME(SOMME.SI.ENS(B2:B26;A2:A26;F5;A2:A26;Tableau2[Colonne1]))}

SVP y a une proposition ? et j’essaye d’éviter le VBA
 

Fichiers joints

Discussions similaires


Haut Bas