Résolu XL 2016 Fonction si sur date et recherche

Jerem6259

XLDnaute Nouveau
Bonjour

Je recherche une formule une formule pour obtenir des résultats d un tableau en fonction du jour.
Exemple si date du jour est un lundi recherche les résultats du jeudi précédent et si date du jour est un mardi affiché les résultats du vendredi dernier si aujourd'hui est un mercredi affiche les résultats de lundi si aujourd'hui est un jeudi affiche les résultats du mardi et si aujourd'hui est un vendredi affiche les résultats du mercredi.

Qui peut m'aider ??
En cellule A1 c'est la formule aujourd'hui ()

Merci
 
Ce fil a été résolu! Aller à la solution…

njhub

XLDnaute Nouveau
Bonjour Jerem6259,

Il manque la position des valeurs à renvoyer, en A1 vous avez aujourdhui(),
Nous sommes dimanche, quelle valeur renvoyer, et le samedi ?
Où trouve t on les dates antérieures à aujourd'hui

lundi​
jeudi​
mardi​
vendredi​
mercredi​
lundi​
jeudi​
mardi​
vendredi​
mercredi​

Si les dates sont en colonne A et les valeurs à renvoyer en colonne C vous pourrez utiliser la formule ci-dessous, formule a adapter à votre tableau
Code:
=SI(ET(JOURSEM(A6)>1;JOURSEM(A6)<4);INDIRECT("C"&EQUIV(A6;A:A;0)-4;1);SI(ET(JOURSEM(A6)>3;JOURSEM(A6)<7);INDIRECT("C"&EQUIV(A6;A:A;0)-2;1);""))
;)
 

Jerem6259

XLDnaute Nouveau
Bonjour Jerem6259,

Il manque la position des valeurs à renvoyer, en A1 vous avez aujourdhui(),
Nous sommes dimanche, quelle valeur renvoyer, et le samedi ?
Où trouve t on les dates antérieures à aujourd'hui

lundi​
jeudi​
mardi​
vendredi​
mercredi​
lundi​
jeudi​
mardi​
vendredi​
mercredi​

Si les dates sont en colonne A et les valeurs à renvoyer en colonne C vous pourrez utiliser la formule ci-dessous, formule a adapter à votre tableau
Code:
=SI(ET(JOURSEM(A6)>1;JOURSEM(A6)<4);INDIRECT("C"&EQUIV(A6;A:A;0)-4;1);SI(ET(JOURSEM(A6)>3;JOURSEM(A6)<7);INDIRECT("C"&EQUIV(A6;A:A;0)-2;1);""))
;)
Bonjour Jerem6259,

Il manque la position des valeurs à renvoyer, en A1 vous avez aujourdhui(),
Nous sommes dimanche, quelle valeur renvoyer, et le samedi ?
Où trouve t on les dates antérieures à aujourd'hui

lundi​
jeudi​
mardi​
vendredi​
mercredi​
lundi​
jeudi​
mardi​
vendredi​
mercredi​

Si les dates sont en colonne A et les valeurs à renvoyer en colonne C vous pourrez utiliser la formule ci-dessous, formule a adapter à votre tableau
Code:
=SI(ET(JOURSEM(A6)>1;JOURSEM(A6)<4);INDIRECT("C"&EQUIV(A6;A:A;0)-4;1);SI(ET(JOURSEM(A6)>3;JOURSEM(A6)<7);INDIRECT("C"&EQUIV(A6;A:A;0)-2;1);""))
;)
Je suis désolé cela ne fonctionne pas. Sûrement du fait de la recherche v . J'ai un classeur et deux feuille. La premiere feuille est un tableau journalier nommé mail où je collecte chaque jour en colonne A la date du jour en B mon stock en colonne C mes entrées et en D mes sorties.

Ma seconde feuille nommé récap.

En A1 c'est la formule aujourd'hui

La colonne B a D se nomme pareil que la feuille "mail" sauf que je souhaite affiché en fonction du jour (cellule A1) des résultats d autres jours.

Si A1 est un lundi recherche mes résultats du jeudi précédent
Si A1 est un.mardi ,je veux ceux du vendredi dernier
Si A1est un mercredi jeudi vendredi affiche les résultats du jour -2 soit lundi mardi mercredi.

Aucune interrogation pour le wk

Merci d avance
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Si tu nous mettais un petit exemple sur fichier, cela aidera à essayer de trouver une réponse à ton problème plutôt que nous laisser faire des suppositions ou de tout reconstruire au hasard.

JHA
 

Jerem6259

XLDnaute Nouveau
Bonjour à tous,

Si tu nous mettais un petit exemple sur fichier, cela aidera à essayer de trouver une réponse à ton problème plutôt que nous laisser faire des suppositions ou de tout reconstruire au hasard.

JHA
Bonjour à tous,

Si tu nous mettais un petit exemple sur fichier, cela aidera à essayer de trouver une réponse à ton problème plutôt que nous laisser faire des suppositions ou de tout reconstruire au hasard.

JHA
Bonjour JHA

Effectivement cela vous aidera certainement . Pas évident de s expliquer clairement dans des fonctions complexes
 

Fichiers joints

njhub

XLDnaute Nouveau
Bonjour Jerem6259,

Voyez si le fichier joint peut vous aider.

Pour le stock :
Code:
=SI(ET(JOURSEM(C2)>1;JOURSEM(C2)<4);INDIRECT("mail!B"&EQUIV(C2;mail.A:A;0)-4;1);SI(ET(JOURSEM(C2)>3;JOURSEM(C2)<7);INDIRECT("mail!B"&EQUIV(C2;mail.A:A;0)-2;1);""))
Pour les entrées :
Code:
=SI(ET(JOURSEM(C2)>1;JOURSEM(C2)<4);INDIRECT("mail!C"&EQUIV(C2;mail.A:A;0)-4;1);SI(ET(JOURSEM(C2)>3;JOURSEM(C2)<7);INDIRECT("mail!C"&EQUIV(C2;mail.A:A;0)-2;1);""))
Pour les sorties :
Code:
=SI(ET(JOURSEM(C2)>1;JOURSEM(C2)<4);INDIRECT("mail!D"&EQUIV(C2;mail.A:A;0)-4;1);SI(ET(JOURSEM(C2)>3;JOURSEM(C2)<7);INDIRECT("mail!D"&EQUIV(C2;mail.A:A;0)-2;1);""))
Pour la date renvoyée :
Code:
=SI(ET(JOURSEM(C2)>1;JOURSEM(C2)<4);INDIRECT("mail!A"&EQUIV(C2;mail.A:A;0)-4;1);SI(ET(JOURSEM(C2)>3;JOURSEM(C2)<7);INDIRECT("mail!A"&EQUIV(C2;mail.A:A;0)-2;1);""))
 

Fichiers joints

Jerem6259

XLDnaute Nouveau
Bonjour Jerem6259,

Voyez si le fichier joint peut vous aider.

Pour le stock :
Code:
=SI(ET(JOURSEM(C2)>1;JOURSEM(C2)<4);INDIRECT("mail!B"&EQUIV(C2;mail.A:A;0)-4;1);SI(ET(JOURSEM(C2)>3;JOURSEM(C2)<7);INDIRECT("mail!B"&EQUIV(C2;mail.A:A;0)-2;1);""))
Pour les entrées :
Code:
=SI(ET(JOURSEM(C2)>1;JOURSEM(C2)<4);INDIRECT("mail!C"&EQUIV(C2;mail.A:A;0)-4;1);SI(ET(JOURSEM(C2)>3;JOURSEM(C2)<7);INDIRECT("mail!C"&EQUIV(C2;mail.A:A;0)-2;1);""))
Pour les sorties :
Code:
=SI(ET(JOURSEM(C2)>1;JOURSEM(C2)<4);INDIRECT("mail!D"&EQUIV(C2;mail.A:A;0)-4;1);SI(ET(JOURSEM(C2)>3;JOURSEM(C2)<7);INDIRECT("mail!D"&EQUIV(C2;mail.A:A;0)-2;1);""))
Pour la date renvoyée :
Code:
=SI(ET(JOURSEM(C2)>1;JOURSEM(C2)<4);INDIRECT("mail!A"&EQUIV(C2;mail.A:A;0)-4;1);SI(ET(JOURSEM(C2)>3;JOURSEM(C2)<7);INDIRECT("mail!A"&EQUIV(C2;mail.A:A;0)-2;1);""))
 

Jerem6259

XLDnaute Nouveau
Bonjour njhub

Ça fonctionne impeccable. Peux t'on avoir les mêmes résultats en tenant compte des jours fériés ??

Merci bcp
 

njhub

XLDnaute Nouveau
Bonjour Jerem6259,

Peux t'on avoir les mêmes résultats en tenant compte des jours fériés ??
Quels jours fériés, de quel pays, de quelle région?

Si le férié tombe un lundi on affiche quel jour?
Si on devait afficher un lundi qui est férié on affiche quel jour?
Les mêmes questions pour les autres jours

C'est faisable si on a les réponses ;)
 

Jerem6259

XLDnaute Nouveau
Bonjour Jerem6259,



Quels jours fériés, de quel pays, de quelle région?

Si le férié tombe un lundi on affiche quel jour?
Si on devait afficher un lundi qui est férié on affiche quel jour?
Les mêmes questions pour les autres jours

C'est faisable si on a les réponses ;)
Bonjour

Je veux décaler les résultats de moins 1 pour les jours fériés de France

Merci beaucoup
 

Jerem6259

XLDnaute Nouveau
Merci pour ton aide.
Pense tu qu'il y a moyen de faire la même chose avec une feuille où je listerai les jours fériés moi même ?
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Bien sûr, en plus des fériés tu peux ajouter les congés, les repos ou autres, comme tu le souhaites.
Il s'agit juste d'une liste de dates quelconque.

JHA
 

Jerem6259

XLDnaute Nouveau
D accord mais tu utilises qu'elles fonction ? Moi je connais nb.jours.ouvres pour tenir compte d une liste de jours définis en amont.
Merci Jha
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Dans le fichier joint au poste 15 la formule utilisée pour savoir si la date se trouve dans la plage "Fer" est:
VB:
ESTNUM(EQUIV($B$7-2;Fer;0))
si la condition est vrai, on soustrait 3 jours à $B$7 sinon on soustrait 2 jours.

JHA
 
Ce message a été identifié comme étant une solution!

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas