Résolu Fonction SI soit en EXCEL ou VBA

anouarlachiri

XLDnaute Occasionnel
Bonjour Forum,

J'ai un petit problème avec la fonction si d'ou sur ma formule j'ai besoin de plusieurs condition, est ce que vous avez des propositions.

Voilà l'explication et ci-joint un exemple de fichier.

en colonne résultats "AE" j'aimerais avoir cette condition :

Si Produit 1 (V1 et V2) colonne "J" et si la date (colonne "M") est > 01/01/2019 donc Résultats (colonne"AE")= Vente AB (colonne"AR")/ 1,09, sinon Résultats= Vente AB+(Vente AF "colonne BJ"/1,09) quelle que soit la date (colonne"M")

Si Produit 2 (V1 et V2) colonne "J", alors Résultat(colonne "AE")= Vente AB+(Vente AF/ 1,07)

Si Porduit 3 (V1 et V2) , Résultats = (Vente AB/1,1 )+(Vente AF/ 1,1)





Merci d'avance :)
 

Fichiers joints

sylvanu

XLDnaute Accro
Supporter XLD
Bonjour Anouarlachiri, James
A noter qu'il manque une info. Donc je suis parti sur si ce n'est rien de prévu alors "Erreur". De plus attention aux désignations : Produit1 -V1, c'est différent de Produit1 - V1.
En mettre AE4 , et à tester. Il n'y a pas d'erreur de syntaxe, mais il faut vérifier toutes les combinaisons.
=SI(ET(M4>=1/1/2019;OU(J4="Produit 1 -V1";J4="Produit 1 -V2"));AR4/1,09;SI(OU(J4="Produit 1 -V1";J4="Produit 1 -V2");AR4+BJ4/1,09;SI(OU(J4="Produit 2 -V1";J4="Produit 2 -V2");AR4+BJ4/1,07;SI(OU(J4="Produit 3 -V1";J4="Produit 3 -V2");AR4+BJ4/1,1;"Erreur"))))
 

Fichiers joints

JBARBE

XLDnaute Barbatruc
Bonjour à tous,
Il y a quelque chose d' incorrect dans ces formules en ce qui concerne la date colonne M :
1ére condition : > au 01/01/2019
2éme condition > quelque soit la date !
Pour moi la 2 éme condition doit être <= 01/01/2019 !
Peut-être je me trompe !
Je vois que les réponses n'ont pas tenu compte d'une date à la 2éme condition ( en effet la 1ére condition est différente de la 2éme )
Alors pourquoi en parler !
bonne journée !
 
Dernière édition:

anouarlachiri

XLDnaute Occasionnel
Merci pour votre réponse @James007 et @sylvanu
la réponse la plus proche de ce que je cherche c'est celle de @sylvanu mais vous avez oubliez une condition de Produit1-V1 quelque soit la date avec la formule : @JBARBE à raison
Résultats= Vente AB+(Vente AF "colonne BJ"/1,09) quelle que soit la date (colonne"M")
Mais je sais pas comment l'ajouter au fichier de @sylvanu

cette formule semble-il logique ?

=SI(ET(M7>=1/1/2019;OU(J7="Produit 1 -V1";J7="Produit 1 -V2"));AR7/1,09;SI(ET(M7<1/1/2019;OU(J7="Produit 1 -V1";J7="Produit 1 -V2"));AR7+BJ7/1,09;SI(OU(J7="Produit 2 -V1";J7="Produit 2 -V2");AR7+BJ7/1,07;SI(OU(J7="Produit 3 -V1";J7="Produit 3 -V2");AR7+BJ7/1,1;"Erreur"))))

Mais ça fonctionne pas comme il faut pour les dates inférieur a 1/1/2019!

Merci
 

anouarlachiri

XLDnaute Occasionnel
Re Merci pour votre intervention j'ai trouvé la solution !

=SI(ET(M4>=DATEVAL("1/1/2019");OU(J4="Produit 1 -V1";J4="Produit 1 -V2"));AR4/1,09;SI(ET(M4<DATEVAL("1/1/2019");OU(J4="Produit 1 -V1";J4="Produit 1 -V2"));AR4+BJ4/1,09;SI(OU(J4="Produit 2 -V1";J4="Produit 2 -V2");AR4+BJ4/1,07;SI(OU(J4="Produit 3 -V1";J4="Produit 3 -V2");AR4+BJ4/1,1;"Erreur"))))


y'avais juste un problème de date, Excel il a pas reconnu votre format de date @sylvanu mais avec la fonction DATEVAL ca fonctionne :)

Merci bien :)
 
Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas