XL 2013 Fonction si plusieurs conditions

zesuila

XLDnaute Occasionnel
Bonjour à tous j'ai besoin de votre aide !
J'ai une feuille dans laquelle je dois donner un résultat selon certaine conditions :
Si A1 = 1 alors C1 = 0
Si A1 = 2 alors C1 = 20
Si A1=3 alors C1 = 40
Si A1=4 ET B1 = 160 alors C1=160
Si A1 = 4 ET B1= 175 Alors C1= 175
J'ai essayé cela : =SI(A1=3;"40€";SI(A1=2;"20€";SI(A1="4";B1="160";"160"))) et ça fonctionne mais il manque la dernière condition ( i A1 = 4 et B1= 175 Alors C1= 175) car là j'ai un message d'erreur - Nombre incorrect d'arguments pour la fonction IF. Celle-ci nécessite entre 2 et 3 arguments, et vous en avez fourni 4. )
Comment puis je faire ?
merci
 

zesuila

XLDnaute Occasionnel
Bonjour à tous
Merci beaucoup, cela fonctionne parfaitement.
J'ai choisi celle de Dranreb (plus courte formule). Elle est presque similaire à celle de JHA sauf qu'il y a EQUIV en moins. Quelle est la différence ?
Encore merci.
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

La fonction de @Dranreb :) que je salue fonctionne car tu demandes le chiffre suivant un index 1;2;3;4 donc si A1 est égal à 2 on prend la seconde donnée donc 20.

La fonction choisir avec equiv permet de rechercher des chiffres autres que 1;2;3;4 et c'est la fonction equiv qui retourne l'index ou la position 1;2;3;4.
exemple:
VB:
=CHOISIR(EQUIV(A1;{10;20;30;40});0;20;40;$B1)
si A1 est égal à 20 alors on retourne la seconde valeur donc 20.

JHA
 

Discussions similaires

Haut Bas