XL 2019 Fonction SI & ET imbriqués

LiFab

XLDnaute Nouveau
Bonjour et merci de me lire,
Je voudrais arriver à avoir une fonction SI imbriqué avec des ET, je n'arrive pas à la faire fonctionner.
Voici ma formule actuelle :
SI(ET(cellule1="CP";cellule2="10");1;SI(ET(cellule1="CP",cellule2="0,5");0,5;Si(cellule1="";0)))
Si je devais décrire en français ce que je veux dire par ma formule :
s'il y a inscrit "CP" et que le salarié à fait 10h alors on doit lui compter 1 CP
S'il y a inscrit "CP" et que le salarié à fait 5h alors on doit lui compter 0.5 CP

Merci par avance pour votre aide.
 

WTF

XLDnaute Occasionnel
Hello,
Dans ton 2ème ET tu as mis une "," au lieu de ";" entre tes 2 conditions.

Essaie cette formule
=SI(ET(cellule1="CP";cellule2=10);1;SI(ET(cellule1="CP";cellule2=5);0,5;""))
 

LiFab

XLDnaute Nouveau
Bonjour WTF et merci pour ta réponse.
En recopiant sur le forum j'ai fait une erreur avec le "," au lieu de ";" dans ma formule il n'y a pas d'erreur. Par contre en reprenant ta formule j'ai compris que ce qui faisait buger excel c'est le fait des mettres des "" sur "10" et "5".
La formule marche maintenant à part pour afficher le 0 s'il n'y a pas la valeur "CP".
Avec ma formule, quand je n'ai pas la valeur "CP" excel affiche ## au lieu du "0" demandé.
Avec ta formule, quand je n'ai pas le valeur "CP" excel n'affiche rien au lieu du "0" demandé.

Je fais un copier/coller de ma formule actuelle pour éviter les erreurs de recopiage :
=SI(ET(AT12="CP";AT41=10);1;SI(ET(AT12="CP";AT41=5);0,5;SI(AT41="";0)))
 

Dim.Reichart

XLDnaute Occasionnel
Bonsoir,
Une affichage ## signifie que la cellule est trop petite pour afficher le contenu, essaye d'agrandir la colonne/ligne.
Personnellement, je ferais comme ceci:
=si(AT12="CP";si.multiple(AT41;10;1;5;0,5;"";0);"0")
 

LiFab

XLDnaute Nouveau
Merci Dim pour cette nouvelle proposition !
Je ne connais pas la fonction multiple mais je vais tester ça.
En rentrant chez moi j'ai réalisé que pour avoir mes fameux 0 qu'il me manque, il fallait juste que je le rajoute à la fin dans la formule de WTF ça marche et ça donne ça :
=SI(ET(AS12="CP";AS41=10);1;SI(ET(AS12="CP";AS41=5);0,5;"0"))
 

WTF

XLDnaute Occasionnel
C'est pareil, il vaut mieux que tu évites les "" autour du 0.
Fais plutot comme ca :

=SI(ET(AS12="CP";AS41=10);1;SI(ET(AS12="CP";AS41=5);0,5;0))
 
Haut Bas