XL 2010 Fonction moyenne réduite avec condition

gui59300

XLDnaute Occasionnel
Bonjour


Je souhaiterais savoir comment faire une moyenne réduite mais en y ajoutant une fonction si.

J’ai beau chercher je ne trouve pas comment faire.


En pj je mets mon exemple le but état de voir la consommation en fonction du pourcentage E85 dans le réservoir.

Bien sûr comme des fois j’ai des valeurs crêtes en max ou mini qui viennent me polluer, je voudrais ne pas les prendre en compte dans le calcul des moyennes. C'est pourquoi j'ai pensé à la formule Moyenne Réduite. Comme je voudrais les résultats par palier de 10% je voudrais rajouter une condition.

J'espère qu'avec l'exemple cela est plus parlant.


Merci d’avance.
 

Fichiers joints

Dernière édition:

JHA

XLDnaute Barbatruc
Bonjour à tous,

Je pense que personne ne comprend ce que tu souhaites avoir comme résultat.
A tout hasard, la fonction moyenne en validation matricielle
Code:
=MOYENNE(SI(($C$6:$C$22>0,1)*($C$6:$C$22<0,5);$I$6:$I$22))
JHA
 

Fichiers joints

gui59300

XLDnaute Occasionnel
Merci pour la réponse mais ce n'est pas ça.
En faite je voudrais calculer une moyenne sauf que je voudrais que dans cette moyenne les valeurs crêtes les plus petites et plus grandes ne soient pas prise en compte.
En général pour cela j'utilise MOYENNE REDUITE, qui fonctionne très bien.
Sauf que là j'ai besoin en plus d'une condition qui est le pourcentage E85.
 

Discussions similaires


Haut Bas