Fonction INDIRECT

JP54

XLDnaute Junior
Bonjour,
J'ai un tableau avec des données et j'essaie de récupéré ces données dans une autre feuille à l'aide de la fonction INDIRECT qui me renvoie "#REF"
Je précise que j'ai suivi un tuto pour faire ce fichier mais le tuto est fait sous Excel 2010 ou 2013
J'ai joint un fichier qui je pense est assez parlant, une feuille "Données" et une autre feuille "Tableau de bord" ou je veux récupéré mes données.
 

Fichiers joints

gosselien

XLDnaute Barbatruc
Bonjour,

en nommant les zones "annee" et "revenus" , un index/equiv fonctionne

en D7: =INDEX(Revenus;EQUIV(C7;ANNEE;0))

P.
 

renyeu

XLDnaute Occasionnel
Bonjour,
A tester en C7:
=INDIRECT("Données!B"&EQUIV(C7;$Données.$A$1:$A$20;0))
puis tirer vers le bas...
La fonction RECHERCHEV me semble plus adaptée:
=RECHERCHEV(C7;$Données!$A$4:$B$20;2)
A suivre
Cdlt
Renyeu
 

JP54

XLDnaute Junior
Ta formule Gosselien fonctionne parfaitement, merci beaucoup.
Par contre la tienne Renyeu ta formule en C7 ne fonctionne pas et je ne vois pas l'erreur.
Pourquoi ma formule ne fonctionne pas?
En C7 =INDIRECT("Données!A"&(4+D1))
En D7 =INDIRECT(C7) INDIRECT(D6)
 

gosselien

XLDnaute Barbatruc
Ta formule Gosselien fonctionne parfaitement, merci beaucoup.
Par contre la tienne Renyeu ta formule en C7 ne fonctionne pas et je ne vois pas l'erreur.
Pourquoi ma formule ne fonctionne pas?
En C7 =INDIRECT("Données!A"&(4+D1))
En D7 =INDIRECT(C7) INDIRECT(D6)
Indirect dans ce cas, n'est pas nécessaire, un "rechercheV" ou "index/equiv" peut convenir, pourquoi aller chercher plus loin et plus compliqué ? :)
 

JP54

XLDnaute Junior
Je n'avais pas eu trop le temps de me pencher sur ta formule pour identifié la partite erreur.
maintenant c'est plus clair, merci
 

Discussions similaires


Haut Bas