fonction extraire des lettres d'une cellule

eul tio pekeu

XLDnaute Nouveau
Bonsoir a tous

tous les soirs j'evolue dans mon domaine est c grace à ce site
j'aimerai résoudre mon probleme avec ce fichier pourquoi j'ai des n/a pourtant la formule est bonne mais je pense que la matrice n'est pas bonne

merci pour votre soutient sur un site génial et encore merci à georgio pour tes précieux conseils
 

Pièces jointes

  • test 2.xls
    15.5 KB · Affichages: 139
  • test 2.xls
    15.5 KB · Affichages: 139
  • test 2.xls
    15.5 KB · Affichages: 131

Samantha

XLDnaute Accro
Re : fonction extraire des lettres d'une cellule

Bonsoir,

dans la formule : =INDEX($E$3:$F$6;EQUIV((STXT(A1;2;1)&STXT(A1;2;1));$E$3:$E$6;0);2) tu recherches en E3:F6 la valeur BB comme excel ne la trouve pas il te répond #N/A!

avec =INDEX($E$3:$F$6;EQUIV((STXT(A1;2;1));$E$3:$E$6;0);2) j'obtiens la réponse "argent"

Il faut donc que tu supprimes &STXT(a1;2;1)

A te lire


Sam
 

eul tio pekeu

XLDnaute Nouveau
Re : fonction extraire des lettres d'une cellule

merci samantha

je ve sélectionner la 2e et 5e lettre qui donne la bonne matiere
mais les 2dernieres lignes sont mq et mr
comment faire?

ps g modifié mon tableau car y avait des erreurs
 

Pièces jointes

  • test 2.xls
    15.5 KB · Affichages: 127
  • test 2.xls
    15.5 KB · Affichages: 132
  • test 2.xls
    15.5 KB · Affichages: 126

Samantha

XLDnaute Accro
Re : fonction extraire des lettres d'une cellule

Re:

Dans la formule suivante
=INDEX($C$3:$F$7;EQUIV((STXT(A1;2;1)&STXT(A1;5;1));$F$3:$F$7;0);2)
Excel recherche exactement la valeur "Be" dans la colonne F (traduction de EQUIV((STXT(A1;2;1)&STXT(A1;5;1));$F$3:$F$7;0)) pour donner comme réponse le contenu de la cellule qui se trouve sur la même ligne dans la 2ème colone de ta matrice soit en colonne E

A mon avis un sommeprod serait mieux venu puisque ta recherche est basée sur 2 critères

Un truc du genre
=SOMMEPROD(($E$3:$E$29=STXT(A1;2;1))*1*($D$3:$D$29=STXT(A1;5;1))*1;$F$3:$F$29)
mais cette formule ne fonctionne pas certainement parce que je ne sais pas encore mixer sommeprod et stxt.... j'ai pourtant bien ajouté les *1 afin de ne pas avoir de pb avec le texte mais.... Tibo, Monique, André : oskour ;)

Sam
 

Monique

Nous a quitté
Repose en paix
Re : fonction extraire des lettres d'une cellule

Bonjour,

Pourquoi tu ne ferais pas l'extraction sur les caractères 2, 6, 7 et 8 ?
En utilisant la même formule, mais validée par ctrl, maj et entrée
ou bien Index(Plage; SommeProd)

Si tu la fais sur les n° 2 et 5,
dans le fichier tu as une formule matricielle, à valider par ctrl,maj et entrée
 

Pièces jointes

  • ExtraireEultiopekeu.zip
    4.1 KB · Affichages: 118

Discussions similaires

Statistiques des forums

Discussions
291 730
Messages
1 917 541
Membres
179 713
dernier inscrit
Ranya
Haut Bas