XL 2016 Fonction ESTNUM

SPARKLETOF

XLDnaute Nouveau
Bonjour,

je voudrais vérifier qu'une cellule contienne un nombre précis.
Pour cela, j'ai trouvé cette formule : =SI(ESTNUM(CHERCHE("1";H8));"OUI";"NON"). En gros cela regarde si dans la cellule il y a le chiffre 1....
Cela fonctionne nickel, en revanche, si la cellule contient le chiffre 11 cela me renvoie "OUI" mais non en fait !!!!
Quelqu'un aurait une idée ?
Merci par avance
SKF
 

SPARKLETOF

XLDnaute Nouveau
Bonjour Victor21,

cette formule fonctionne avec 11 uniquement. Si je met 12 cela renvoie "oui".....
Merci pour votre aide
 

Chris24

XLDnaute Impliqué
Supporter XLD
Bonjour SPARKLETOF? Victor21

Et comme ceci

=SI(NBCAR(H8)-NBCAR(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(H8;0;"");1;"");2;"");3;"");4;"");5;"");6;"");7;"");8;"");9;""))=1;"Oui";"Non")


Cdt
 

chris

XLDnaute Barbatruc
Bonjour à tous

Pourquoi pas tout simplement =SI(H8=1; "OUI";"NON") ?

Il y a quoi en fait dans H8 ?
 

SPARKLETOF

XLDnaute Nouveau
Salut chris,
c'est vrai que je n'ai pas spécifié cette information importante...désolé !
En fait, dans cette cellule il y a des infos de ce type : 1,3,8,12 (avec des chiffres allant de 1 à 14).
@Victor21 : si je copie ta formule, cela me dis que le niveau d'imbrication est trop élevé.
 

chris

XLDnaute Barbatruc
RE

VB:
=SI(OU(GAUCHE(A1;2)="1,";DROITE(A1;2)=",1";ESTNUM(CHERCHE(",1,";A1)));"Oui";"Non")
 

Roblochon

XLDnaute Impliqué
Bonjour,
Bonjour @chris, @Victor21 ,

Est-ce que ça le ferait : SI(ESTNUM(TROUVE(",1,";","&H8&","));"Oui";"Non")

Bonne journée

Edition: correction apportée ",1," dans "," &H8&","
 
Dernière édition:

Discussions similaires


Haut Bas