Fonction CHERCHE renvoie #VALEUR!

criscris11

XLDnaute Accro
Salut à tous,
Afin de finaliser mon fichier (voir mes précédents posts), je bute sur une formule qui me renvoie #VALEUR! alors que extrayant le résultat manuellement je trouve la bonne valeur.
Cf. fichier-joint.
Merci d'avance et bonne journée à tous.
 

Fichiers joints

vbacrumble

XLDnaute Accro
Re : Fonction CHERCHE renvoie #VALEUR!

Bonjour

Que penses-tu de cette formule ?

Code:
=SUPPRESPACE(STXT(O1;CHERCHE("/C";O1)-2;4))

EDITION
: pour gérer les messages d'erreur
Code:
[B]=SI(NON(ESTNUM(SUPPRESPACE(STXT($O1;CHERCHE("/C";$O1)-2;2))*1));"";SUPPRESPACE(STXT($O1;CHERCHE("/C";$O1)-2;2))*1)[/B]
 
Dernière édition:

criscris11

XLDnaute Accro
Re : Fonction CHERCHE renvoie #VALEUR!

Bonjour vbacrumble,
Je viens juste de voir ton édition : je vais tester mais je cherche uniquement à extraire le chiffre ou le "SN" car la dernière lettre est déjà extraite par formule dans le colonne O dans le fichier original.
Merci d'avance.
 

vbacrumble

XLDnaute Accro
Re : Fonction CHERCHE renvoie #VALEUR!

Re

Avec cette formule
=SUPPRESPACE(STXT($O1;CHERCHE("/C";$O1)-2;2))

J'extrais bien soit SN soit 4 soit 6 non ?
 

criscris11

XLDnaute Accro
Re : Fonction CHERCHE renvoie #VALEUR!

Re,
Oui effectivement, ta formule extrait bien le 6 ou le 4 mais pas le SN.
Merci pour ce début de piste en tout cas et bonne journée à toi.
 

Gael

XLDnaute Barbatruc
Re : Fonction CHERCHE renvoie #VALEUR!

Bonjour Criscris, Vbacrumble,

Dans le même esprit avec les tests pour N1:

Code:
=SI(O1="";"";SI(N1="SN/C";"6";SI(ESTERREUR(CHERCHE("SN";O1));STXT(O1;CHERCHE("/";O1)-1;1);"SN")))
Sinon, ta formule originale ne pourrait marcher qu'en testant l'erreur ou non de la fonction Cherche qui renvoie #VALEUR si elle ne trouve pas les caractères cherchés. Mais cela faisait une formule trop longue avec trop de conditions imbriquées de type Non(esterreur(cherche...

@+

Gael
 

Gael

XLDnaute Barbatruc
Re : Fonction CHERCHE renvoie #VALEUR!

Re,

j'insiste aussi, la formule de VBAcrumble marche très bien et est plus élégante et concise.

Et en ajoutant les autres conditions:

Code:
=SI(O1="";"";SI(N1="SN/C";6;SUPPRESPACE(STXT($O1;CHERCHE("/C";$O1)-2;2))))
@+

Gael
 
Dernière édition:

criscris11

XLDnaute Accro
Re : Fonction CHERCHE renvoie #VALEUR!

Re, bonjour Gael,
Merci à tous les deux : je teste tout çà et je vous tiens au courant.
Bon appétit et bon après-midi.
 

criscris11

XLDnaute Accro
Re : Fonction CHERCHE renvoie #VALEUR!

Re,
Merci à tous les deux pour votre proposition qui fonctionne bien sur le fichier démo mais pas dans mon fichier original.
La formule (qui doit être en colonne R) ne donne en aucun cas le résultat attendu : j'ai copié la formule en R53 (là ou cela ne fonctionnait pas avant) et j'obtiens toujours rien.
Si vous pouviez regarder, cela sera sympa et surtout je pourrais enfin finaliser ce fichier commencé en 2007.
Si vous avez des questions concernant le fichier, n'hésitez surtout pas je ne bouge pas de l'après-midi.

@vbacrumble : je n'ai jamais douté de ta formule ;), sois en certain.
Bon après-midi.
 

Fichiers joints

vbacrumble

XLDnaute Accro
Re : Fonction CHERCHE renvoie #VALEUR!

Re


En reprenant la formule de Gael et la mienne modifiée ainsi
Code:
[B]=SI(O39="";"";SI(N39="SN/C";6;SUPPRESPACE(STXT($O39;CHERCHE("[COLOR="Red"]/*[/COLOR]";$O39)-2;2))))[/B]
C'est bon non ?
 

criscris11

XLDnaute Accro
Re : Fonction CHERCHE renvoie #VALEUR!

Re,
On touche au but. Peut-on chercher plusieurs occurrences dans la formule (par exemple un mot) ou plutôt chercher si la formule en O ne contient pas "avancement" car tout ce qui est plafonnement avancement est extrait dans la colonne d'à côté.
J'espère être assez clair sinon fais le moi savoir, j'essaierai de t'expliquer avec des exemples.
Merci encore.

Une piste : si cherche "avancement" en O alors "". Peut-on inclure cette condition dans ta formule sans chambouler le reste des conditions ?
 
Dernière édition:

criscris11

XLDnaute Accro
Re : Fonction CHERCHE renvoie #VALEUR!

Re,
vbacrumble : peut-on obtenir le même résultat uniquement si on trouve le mot "notation" dans la colonne O ?
Si c'est faisable, cela devrait être jouable.
Bonne soirée en attendant.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas