XL 2016 Faire un tableau de synthèse

Mic29

XLDnaute Nouveau
Bonjour.
Je cherche un moyen pour obtenir un tableau de synthèse en fonction des données saisie dans le modèle joint.
Lorsque je saisie des années dans une colonne , j'aimerai pouvoir éditer automatiquement (car le fichier d'origine sur lequel je travaille est plus conséquent) une feuille qui ne me donne que le nom, prénom, la colonne où sont saisies les année avec les données correspondantes de la colonne 2 et 3. (j'ai mis dans l'onglet final le résultat final souhaité).
J'espère avoir été assez clair.
Merci
 

Pièces jointes

  • exemple.xlsx
    10.5 KB · Affichages: 10

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Mic,
Un essai en PJ avec :
VB:
=SIERREUR(INDEX(initial!$B$7:$B$10;EQUIV($D7;DECALER(initial!$D$7:$D$10;0;EQUIV($D$6;initial!$D$6:$M$6;0)-1);0));"")
A adapter à votre fichier final.
A noter que je remonte rien lorsque l'année n'est pas précisée.
 

Pièces jointes

  • exemple (2).xlsx
    10.3 KB · Affichages: 3

sylvanu

XLDnaute Barbatruc
Supporter XLD
J'ai fait d'après ce que j'ai compris.
En PJ j'ai mis des listes déroulantes pour les unités et les années.
Ce que j'ai compris : en feuille final, on choisit l'unité et les années, la synthèse remonte les codes et les intitulés.
 

Pièces jointes

  • exemple (2) (1).xlsx
    11.7 KB · Affichages: 3

Discussions similaires

Haut Bas