XL 2010 extraire une partie des données dans une autre cellule

Jessie39

XLDnaute Nouveau
Bonjour,

J'ai une base de données classiques (1100 lignes) dont je souhaite extraire une partie du libellé de la cellule et le mettre automatiquement dans une autre cellule afin de pouvoir ensuite faire des recherche V. Je ne suis pas sûre d'être très claire ! Je vous mets en pièce jointe une illustration.

Je ne trouve pas le moyen d'obtenir le résultat dans la colonne C comme indiqué dans mon petit tableau ci-joint. Je ne sais même pas si excel est capable de cela ?

En tous les cas, si vous avez des pistes et autres moyens pour répondre à ce problème, je suis preneuse !

Merci beaucoup pour votre aide.

Belle journée
 

Fichiers joints

Roblochon

XLDnaute Occasionnel
Bonjour,

En C5 formule à tirer vers le bas: =STXT(A5;TROUVE("(";A5)+1;TROUVE(")";A5)-TROUVE("(";A5)-1)

bonne journée
 

don_pets

XLDnaute Occasionnel
Hello,

une solution serait de mettre cette fonction dans un module :
VB:
Function NumChaine(chaine)
Application.Volatile
TempChaine = Trim(Application.Substitute(chaine, ",", "."))
Temp = ""
For I = 1 To Len(TempChaine)
c = Mid(TempChaine, I, 1)
If c >= "0" And c <= "9" Or c = "." Then Temp = Temp & c
Next I
NumChaine = Val(Temp)
End Function
et ensuite en C5 tu mets =NumChaine(A5)
 

Jessie39

XLDnaute Nouveau
Je reviens vers vous pour une dernière question : je souhaite dans une cellule qu'excel à cumuler les données se trouvant dans une autre feuille. Je pensais faire une recherchV mais je n'y arrive pas. Un nouveau fichier ci-joint pour illustration. Merci par avance !
 

Fichiers joints

Jessie39

XLDnaute Nouveau
Hello,

une solution serait de mettre cette fonction dans un module :
VB:
Function NumChaine(chaine)
Application.Volatile
TempChaine = Trim(Application.Substitute(chaine, ",", "."))
Temp = ""
For I = 1 To Len(TempChaine)
c = Mid(TempChaine, I, 1)
If c >= "0" And c <= "9" Or c = "." Then Temp = Temp & c
Next I
NumChaine = Val(Temp)
End Function
et ensuite en C5 tu mets =NumChaine(A5)
Houlala, ça dépasse complètement mes bases en excel !!! Mais merci tout de même !
 

Roblochon

XLDnaute Occasionnel
Re,

Même s'il est préférable d'ouvrir une nouvelle discussion lorsqu'on change de sujet, je vais vous répondre ici.

En J5 : =SOMME.SI(Feuil2!C6:C11;Feuil1!C5;Feuil2!I6:I11)

Dans votre exemple je n'ai pas pu savoir de quelle colonne exacte il fallait cumuler les données. J'ai pris Feuil2!I6:I11

cordialement

Je reviens vers vous pour une dernière question : je souhaite dans une cellule qu'excel à cumuler les données se trouvant dans une autre feuille. Je pensais faire une recherchV mais je n'y arrive pas. Un nouveau fichier ci-joint pour illustration. Merci par avance !
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour Jessie39, Roblochon,

Pour additionner directement part salariale et patronale en J5 j'aurai mis

VB:
=SOMMEPROD((Feuil2!$C$6:$C$11=C5*1)*Feuil2!$I$6:$J$11)
Cordialement
 

Jessie39

XLDnaute Nouveau
Re,

Même s'il est préférable d'ouvrir une nouvelle discussion lorsqu'on change de sujet, je vais vous répondre ici.

En J5 : =SOMME.SI(Feuil2!C6:C11;Feuil1!C5;Feuil2!I6:I11)

Dans votre exemple je n'ai pas pu savoir de quelle colonne exacte il fallait cumuler les données. J'ai pris Feuil2!I6:I11

cordialement
Merci. Par contre, il faut qu'excel cumule les données de la colonne I + J et pas que les données de la colonne I. Qu'est-ce qu'il faut rajouter dans la formule ?
 

Jessie39

XLDnaute Nouveau
Bonjour le Forum,
Bonjour Jessie39, Roblochon,

Pour additionner directement part salariale et patronale en J5 j'aurai mis

VB:
=SOMMEPROD((Feuil2!$C$6:$C$11=C5*1)*Feuil2!$I$6:$J$11)
Cordialement
Merci. Par cette solution, ça marche très bien également. Trop fort !
 

Discussions similaires


Haut Bas