Extraire les données d'un tableau

ciannamea

XLDnaute Nouveau
Bonsoir,

Je souhaiterai extraire les données de la feuille 1 sur la base du menu déroulant de la feuille 2.
En sélectionnant le type de pieux ( TC,FS,FT ou FB) dans le menu déroulant de la cellule A1 de la feuille2; je souhaiterai obtenir ( en feuille2 ) le libellé et le prix correspondant au type de pieux.
J'ai utiliser la fonction suivante, mais elle ne me permet de modulé en fonction du type de pieux.
=SIERREUR(INDEX(Feuil1!$A$1:$A$10;PETITE.VALEUR(SI(Feuil1!$B$1:$B$17<>"";LIGNE(Feuil1!$B$1:$B$17));LIGNE()));"")
Je vous joint un fichier correspondant,
Vous remerciant par avance.
 

Fichiers joints

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonjour @ciannamea, @djidji59430,

Une autre méthode qui permet de se passer de formules matricielles couteuses en ressources et en temps de calcul.
On ajoute une colonne devant le tableau de Feuil1:
  • cette colonne contient en première cellule le rang du type de pieu choisi au sein de la première ligne du tableau
  • les cellules suivantes de la colonne contiennent le numéro de ligne du tableau si la cellule correspondant au pieu choisi n'est pas vide
On a donc ainsi une lecture directe des valeurs (ligne et colonne) des valeurs à prendre en compte. Ce qui simplifie les formules de Feuil2.
 

Fichiers joints

Dernière édition:

ciannamea

XLDnaute Nouveau
Bonsoir,
Faisant suite à votre réponse de dimanche, dont je vous remercie,
pourriez-vous m'indiquer la marche à suivre pour déplacer les extractions.
Pour se faire je vous joint un fichier.
Vous remerciant par avance,
Bien cordialement.
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas