extraire les données d'un tableau pour créer un sous-tableau

AnGa

XLDnaute Nouveau
Bonjour.

je possède un tableau de base où l'une des colonnes ne possèdent que 5 entrées (5 fruits dans l'exemple qui suit).

je souhaiterai créer des des sous-tableaux qui se remplissent automatiquement qu'il y a de fruits.

j'ai conscience que mes explications et ma demande sont bancales, je ne trouve pas les mots pour m'expliquer clairement. j'espère donc que l'exemple qui accompagne ce texte sera beaucoup plus parlant..

merci pour toute aide apportée.
 

Fichiers joints

Chris401

XLDnaute Accro
Bonjour
Avec cette formule matricielle (validation avec CTRL+Maj+Entrée)

Pour les pommes (titre en A17)

Retour des dates :
Code:
=SIERREUR(PETITE.VALEUR(SI(Tableau1[gamme]=$A$17;Tableau1[date]);LIGNE(A1));"")
Retour des nombres :
Code:
=SIERREUR(PETITE.VALEUR(SI(Tableau1[gamme]=$A$17;Tableau1[nombre]);LIGNE(A1));"")
 
Dernière édition:

AnGa

XLDnaute Nouveau
Bonjour.

Merci pour ces commandes. c'est exactement ce que je voulais, mais le souci au niveau des nombres, ils se mettent automatiquement du plus petit au plus grand et ne correspondent donc pas à la date qui est en face...
 

Chris401

XLDnaute Accro
Bonsoir
Au temps pour moi ; je suis allé trop vite.
Pour la formule en B19 :
Code:
=SI([@date]="";"";SOMMEPROD((Tableau1[date]=[@date])*(Tableau1[gamme]=$A$17);Tableau1[nombre]))
 

Discussions similaires


Haut Bas