Extraire les données d'un tableau lorsque les colonnes ne sont pas contiguës

tamatave33

XLDnaute Junior
Bonjour le forum,

Dans un tableau je voudrais extraire les données en fonction du contenu de plusieurs cellules.
Dans mon exemple, en fonction du contenu des cellules B16 (Type), C16 (Hauteur) et D16 (Longueur), je voudrais extraire la valeur de la cellule du tableau qui correspond à ces 2 conditions. Le problème est que dans mon tableau, les colonnes qui contiennent les valeurs à trouver ne sont pas contiguës, elles sont décalées d'une colonne.
Si j'écris la formule :
=SI(B16="10 Nu";INDEX((D24:D26;F24:F26;H24:H26;J24:J29;L24:L29);EQUIV(D16;B24:B29;0);EQUIV(C16;(D21;F21;H21;J21;L21);0)))
Ce n'est pas bon.
Merci pour votre aide
 

Fichiers joints

Discussions similaires


Haut Bas