Extraire le numeros cité deux fois ou une fois

Guido

XLDnaute Accro
Bonjour le Forum

Je reviens vers Vous..pour une nouvelle demande..

Je desire faire afficher parmi les numeros qui se trouve dans la plage

AD2:AD5 si il est cité aussi dans la plage AF2:AF5 ou dans la plage AH2:AH

voire meme dans les deux plage dans la cellule AC9,et si il y à deux numeros

faire s'affiché le second dans la cellule AC15.

Si pas de citation on fais l'impasse.

Merci d'avance

Le fichier avec ma demande et mon désire je l'ai manuellement..

Merci d'avance

Une seconde demande suivras...???

D'avance Merci

Guido
 

Fichiers joints

Noel Bedard

XLDnaute Occasionnel
Bonjour Guido et le forum,

VB:
Dans la cellule AC9

=SI(NB.SI(AF2:AH5;AD2)>=2;AD2;SI(NB.SI(AF2:AH5;AD3)>=2;AD3;SI(NB.SI(AF2:AH5;AD4)>=2;AD4;SI(NB.SI(AF2:AH5;AD5)>=2;AD5;0))))

Dans la Cellule AC15

=SI(ET(NB.SI(AF2:AH5;AD2)>=2;AC9<>AD2);AD2;SI(ET(NB.SI(AF2:AH5;AD3)>=2;AC9<>AD3);AD3;SI(ET(NB.SI(AF2:AH5;AD4)>=2;AC9<>AD4);AD4;SI(ET(NB.SI(AF2:AH5;AD5)>=2;AC9<>AD5);AD5;0))))
Peut-être ces formules ci, à tester.

Edité après affichage du post.
Après vérification c'est pas bon, car si vous avez la même valeur dans la même colonne ça sera calculé mais nous voulons uniquement les valeurs identiques sur les autres colonnes.
Je continue à chercher.
Désolé


Bonjour et bonne journée
Noël
 

Fichiers joints

Dernière édition:

Guido

XLDnaute Accro
Bonjour Noel

Merci pour tes propositions

Onglet C4.....C5.....je trouve juste

Onglet C7 la Non ?????

Apres avoir copié les deux formules …rien ne s'affiche

alors que le resultats esperé devrais etre ….

Dans AC9…le numero 7

et dans AC19…..le numero 11

Merci pour ton aide.

Guido
 

Fichiers joints

Noel Bedard

XLDnaute Occasionnel
Bonjour,
J'ai corrigé ces 2 lignes pour l'instant, je cherche une autre solution.
J'avais oublié d'ajouter la valeur que je prenais pour comparer avec les autres colonnes. Ce qui fait qu'il ignorait la valeur de la colonne AD.

Code:
AC9
=SI(NB.SI(AF2:AH5;AD2)>=1;AD2;SI(NB.SI(AF2:AH5;AD3)>=1;AD3;SI(NB.SI(AF2:AH5;AD4)>=1;AD4;SI(NB.SI(AF2:AH5;AD5)>=1;AD5;0))))

AC15
=SI(ET(NB.SI(AF2:AH5;AD2)>=1;AC9<>AD2);AD2;SI(ET(NB.SI(AF2:AH5;AD3)>=1;AC9<>AD3);AD3;SI(ET(NB.SI(AF2:AH5;AD4)>=1;AC9<>AD4);AD4;SI(ET(NB.SI(AF2:AH5;AD5)>=1;AC9<>AD5);AD5;0))))
[/Code¨]
 

Noel Bedard

XLDnaute Occasionnel
Bonjour,
C'est vraiment pas bon mon affaire,
Maintenant ma ligne compare les valeurs de la première colonne avec les deux autres mais pas les autres avec la première.
Il tard ici, je serais mieux d'aller me coucher rien ne fonctionne.
Excusez-moi, je continue à chercher

Bonne journée
Noël
 

Noel Bedard

XLDnaute Occasionnel
Bonsoir Guido et le Forum.

Pour moi ce fût un beau challenge, merci.

Je vous retourne le fichier avec les formules incluses dans les trois feuilles.
J'y suis allé avec une formule très très longue, car je ne connais pas assez la programmation. J'ai fais cellule par cellule.

Peut-être qu'un membre plus qualifié pourrait nous instruire sur une meilleur façon de faire.
Pour l'instant ça semble fonctionner.

Bien à vous,
Noël
 

Fichiers joints

Guido

XLDnaute Accro
Re

Bonsoir Noel

Merci pour tes propositions finales,

Je vais mettre en places les formules dans le fichier final,,et je te dis..

a plus

Guido
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas