Extraire d'une colonne une partie des donnees

fanadegra

XLDnaute Occasionnel
[Résolu] Extraire d'une colonne une partie des donnees

Bonjour à tous et merci d'avance pour votre aide

J'ai en colonne A ce type de données

48000 -- femelles -- Plat -- 2100 mètres, Corde à droite -- Handicap Course D

(je souhaite dispatcher certains mots dans les colonnes à coté)

je joins un fichier qui indique ce que je souhaite obtenir.

j'ai fait une recherche sur le forum avec les fonctions droite, subtitue et cherche mais malgré mes tests j'arrive pas au résultat pour faire une formule qui recherche par exemple plusieurs mots clé






Merci
Version xls 2007
 

Fichiers joints

Dernière édition:

Tibo

XLDnaute Barbatruc
Re : Extraire d'une colonne une partie des donnees

Bonsoir,

Une solution à base de formules sans colonne intermédiaire :

en B5 :

Code:
=SI(SOMMEPROD((ESTNUM(CHERCHE({"Autostart";"Haies";"Plat";"Steeple";"Attelé";
"Monté";"Cross";"ST-Chase"};$A5))*1))=0;"";INDEX({"Autostart";"Haies";"Plat";
"Steeple";"Attelé";"Monté";"Cross";"ST-Chase"};EQUIV(VRAI;ESTNUM(CHERCHE(
{"Autostart";"Haies";"Plat";"Steeple";"Attelé";"Monté";"Cross";"ST-Chase"};$A5
));0)))
en C5, sur le même principe :

Code:
=SI(SOMMEPROD((ESTNUM(CHERCHE({"Amateurs";"Lads";"Cavalières"};$A5))*1))=0;"";
INDEX({"Amateurs";"Lads";"Cavalières"};EQUIV(VRAI;ESTNUM(CHERCHE({"Amateurs";
"Lads";"Cavalières"};$A5));0)))
Je te laisse poursuivre pour D5 et E5.

@+
 

fanadegra

XLDnaute Occasionnel
Re : Extraire d'une colonne une partie des donnees

Merci Tibo pour la formule, cela va me servir pour les colonnes suivantes, je vas me débrouiller pour les colonnes à coté

dans mon fichier il y a une deuxième question à partir de la ligne 44

en gros je cherche les caractères suivants "n'ayant pas gagné"

dans 80 % des cas il y a un nombre à 4 5 ou 6 chiffres à extraire 8.000 ou 30000 ou 100000
et dans 20 % des cas il y a du texte (ex n'ayant pas gagné une listed race)


merci pour cette superbe réponse Tibo, je me mets à reprendre ta formule sur les colonnes semblables
 

Tibo

XLDnaute Barbatruc
Re : Extraire d'une colonne une partie des donnees

re,

Pour A44, une autre formule :

Code:
=SI(ESTNUM(CHERCHE("n'ayant jamais gagné";A44));"N'ayant jamais gagné";SI(
ESTNUM(CHERCHE("n'ayant pas gagné";A44));SI(ESTNUM(STXT(A44;CHERCHE("N'ayant pas
 gagné";A44)+18;1)*1);"";GAUCHE(STXT(A44;CHERCHE("N'ayant pas gagné";A44)+18;
99);CHERCHE("µ";SUBSTITUE(STXT(A44;CHERCHE("N'ayant pas gagné";A44)+18;99);
" ";"µ";3))));""))
Je te laisse tester

@+
 

fanadegra

XLDnaute Occasionnel
Re : Extraire d'une colonne une partie des donnees

Je teste et je te dis.

Pour la 1ère partie tout est nikel
 

fanadegra

XLDnaute Occasionnel
Re : Extraire d'une colonne une partie des donnees

re,

Pour A44, une autre formule :

Code:
=SI(ESTNUM(CHERCHE("n'ayant jamais gagné";A44));"N'ayant jamais gagné";SI(
ESTNUM(CHERCHE("n'ayant pas gagné";A44));SI(ESTNUM(STXT(A44;CHERCHE("N'ayant pas
 gagné";A44)+18;1)*1);"";GAUCHE(STXT(A44;CHERCHE("N'ayant pas gagné";A44)+18;
99);CHERCHE("µ";SUBSTITUE(STXT(A44;CHERCHE("N'ayant pas gagné";A44)+18;99);
" ";"µ";3))));""))
Je te laisse tester

@+
en collant la formule de E44 à E50 cela fonctionne en partie (car j'ai bien "n'ayant jamais gagné" et "une listed race"
par contre en e49 j'ai sans le souhaiter "105.000. - Recul"
j'ai des # que je vais masquer avec des caractères blancs


en b44 je souhaite extraire les données chiffrées apparaisant après "n'ayant pas gagné" soit le resultat "30.000." ou mieux "30000"
je pourrais ensuite faire la colonne C et D

merci encore pour ton aide, je vois que cela avance grâce à toi et j'apprends petit à petit
 

Tibo

XLDnaute Barbatruc
Re : Extraire d'une colonne une partie des donnees

Bonjour,

Regarde le fichier avec la formule.

J'ai sans doute eu un souci lors du copier/coller de la formule sur le Forum hier soir

@+
 

Fichiers joints

fanadegra

XLDnaute Occasionnel
Re : Extraire d'une colonne une partie des donnees

Bonjour Tibo,
Bonjour le forum,

effectivement cela fonctionne impec pour la colonne E pour extraire le texte.

je vais tenter de comprendre la formule et de l'adapter pour extraire les chiffre pour les colonnes b et c.

Je pars en rdv, je tente d'adapter et je reviens cet am pour indiquer si j'ai réussi

Merci pour ton aide et à tout à l'heure
 
Dernière édition:

fanadegra

XLDnaute Occasionnel
[Résolu]: Extraire d'une colonne une partie des donnees

après pas mal de recherche sur cette phrase
Pour 6, 7 et 8 ans, n'ayant pas gagné 105.000. - Recul de 25 m. à 53.000.

j'arrive à extraire le 1er chiffre en passant par 2 colonnes et pareil pour l'autre chiffre avec 2 autres colonnes
j'utilise cette formule :
=STXT(A4;TROUVE("n'ayant pas gagné";A4);9999)
ensuite je subtitue le texte par ""


Merci pour ton aide je vais mettre résolu en intitulé même si je suis preneur d'une formule plus simple que la mienne
 

Tibo

XLDnaute Barbatruc
Re : Extraire d'une colonne une partie des donnees

re,

Peux-tu dire ce que tu souhaites obtenir en ce qui concerne la phrase de ton dernier post ?

A te (re)lire

@+
 

fanadegra

XLDnaute Occasionnel
Re : Extraire d'une colonne une partie des donnees

Pour 6, 7 et 8 ans, n'ayant pas gagné 105.000. - Recul de 25 m. à 53.000.
sur la phrase ci dessus avec ma formule j'obtiens
105.000. - Recul de 25 m. à 53.000.

je souhaite obtenir simplement 105000 sur une colonne
et sur une autre colonne 53000

Donc l'idéal serait que la formule cherche "n'ayant pas gagné"
et prenne le chiffre à droite en s'arretant au "."

et la formule de la colonne d'à coté est la meme en cherchant "- Recul de 25 m. à" et s'arretant au point car il peut y avoir d'autres caractères ensuite

merci Tibo
 

Discussions similaires


Haut Bas