Extraction valeur cellule sur plusieurs colonne index equiv ?

starz

XLDnaute Occasionnel
Bonjour,
Je cherche à extraire d'un tableau à plusieurs colonnes le prix pour chaque référence qui y est associé. le résultat obtenu devient donc une liste sur une colonne.
Je n'arrive pas à écrire la formule, pouvez vous m'aider.
Je joint un exemple.

merci
 

Fichiers joints

mth

XLDnaute Barbatruc
Re : Extraction valeur cellule sur plusieurs colonne index equiv ?

Bonjour

Essaie avec cette formule en J2 et tirée vers le bas:
Code:
=INDEX(D2:I2;1;EQUIV(9^9;D2:I2))
Bonne journée,

mth

Edit: :) Bonjour gillesdemev :)
bon réflexe, on se fait de ces noeuds au cerveau parfois .... (enfin je parle pour moi)
Merci à toi et bonne journée :)
m
 
Dernière édition:

gillesdemev

XLDnaute Junior
Re : Extraction valeur cellule sur plusieurs colonne index equiv ?

Bonjour tout le monde,
je propose cette formule
=(SOMME(D2:I2)*C2) 'si tu tiens compte de la quantité
sinon
=SOMME(D2:I2)
à tirer aussi vers le bas
à condition qu'il n'y ai qu'une seule valeur par ligne entre D et I
Enfin si j'ai bien compris le probléme
Amitié à tous
Gilles
 

starz

XLDnaute Occasionnel
Re : Extraction valeur cellule sur plusieurs colonne index equiv ?

merci à tous les 2 ! le truc tout bête SOMME en effet :D
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas