Extraction sans doublons de deux colonnes par paire

pierreed

XLDnaute Nouveau
Bonjour,

Je possède un tableau à deux colonnes avec des valeurs redondantes.

Les valeurs de chaque lignes sont liées en binôme.

Je souhaiterais faire une extraction sans doublons des binômes dans un autre tableau à deux colonnes.

Ex :

A/B
x / y
y / z
z / k
x / y
y /z
z / i

=>

D/E
x / y
y / z
z / k
z / i

Dans l'idée j'ai deux formules :

=DECALER($A$1;ENT((LIGNES($1:2)-1)/3);(LIGNES($1:2)-1)-ENT((LIGNES($1:2)-1)/3)*3)

=SIERREUR((INDEX(Li;PETITE.VALEUR(SI(FREQUENCE(SI(Li<>"";EQUIV(Li;Li;0)); LIGNE(Li)-LIGNE($C$3)+1);LIGNE(Li)-LIGNE($C$3)+1);LIGNES(Z$3:Z3))));"")

Mais je n'arrive pas à les combiner :(

Dans l'attente de votre aide
 

Discussions similaires


Haut Bas