Extraction de doublons en ignorant certaines colonnes

no vice ma kro

XLDnaute Nouveau
Bonjour,

Je souhaiterais supprimer d'une feuille les lignes dont le contenu de la totalité de ses cellules, excepté celles de certaines colonnes (que l'on ne prendra pas en compte pour la comparaison) est identique à celui de lignes précédentes.

La question des doublons a déjà été traitée sur le forum mais la particularité de ma requête tient au fait que certaines colonnes ne sont pas prises en compte.

Merci pour votre attention
François
 

Fichiers joints

M12

XLDnaute Impliqué
Bonjour

A tester en mettant le code dans un module où sur la feuille concernée

Code:
Sub Doublons()
Dim DernLigne As Long
DernLigne = Range("A" & Rows.Count).End(xlUp).Row
    Range("A1:F" & DernLigne).Select
    ActiveSheet.Range("$A$1:$F$" & DernLigne).RemoveDuplicates Columns:=Array(3, 4, 5, 6), _
        Header:=xlNo
Range("A1").Select
End Sub
 

no vice ma kro

XLDnaute Nouveau
Merci à M12 et Cisco pour vos réponses rapides.
La solution de Cisco fonctionne sauf si il y a une cellule vide, et mon fichier en était rempli.
Entre temps, j'avais résolu mon problème en concaténant plusieurs colonnes dans une seule (du style =A1&B1&D1)
puis en appliquant sur la colonne d'à côté la formule =SI(NB.SI($E$1:E1;E1)>1;"Doublon";"").
Et finalement, cela m'allait bien pour moi.
Encore merci pour le temps que vous m'avez accordé.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas