XL 2016 Extraction de Données

KTM

XLDnaute Occasionnel
Salut cher Forum
J'ai une plage de données de laquelle je voudrais extraire les ID qui ont changé leur PROTOCOLES en "x" et les afficher dans une autre plage
Ci joint un fichier pour la demo Merci
 

Fichiers joints

KTM

XLDnaute Occasionnel
Bonjour à tous,

Un exemple par formule

JHA
Merci JHA
Mais il ya peut etre quelque chose qui manque à la Formule.
Il se peut aussi que je me sois mal expliqué.
on devrait avoir normalement:
H de protocole g est passé à x
G
de a est passé à x
U
de e est passé à x

J'ai réexpliqué dans le fichier joint .Merci.
S'il ya une alternative par macro je suis aussi preneur.
 

Fichiers joints

Amilo

XLDnaute Accro
Bonjour KTM, JHA, le forum,

Une proposition avec Power query,

J'ai quelques doutes sur le résultat attendu :
- Faut-il tenir compte de l'ordre de changement des protocoles ?
Que faut-il indiquer si un protocole passe de "a" à "x" ou bien de "x" à "a" : (dans cet ordre "xa" ou celui-ci "ax" ?)

- Que faut-il indiquer si un protocole comporte plusieurs valeurs distinctes à savoir a, d, g, x : ("ax" ou "adgx" ou autres ?) Idem pour l'ordre ?

- Est-ce que votre fichier réel comporte bien uniquement des lettres et des x ou ce sont plutôt des mots ?

Aussi pas certain que le résultat soit celui voulu

Bonne soirée
 

Fichiers joints

KTM

XLDnaute Occasionnel
Bonjour KTM, JHA, le forum,

Une proposition avec Power query,

J'ai quelques doutes sur le résultat attendu :
- Faut-il tenir compte de l'ordre de changement des protocoles ?
Que faut-il indiquer si un protocole passe de "a" à "x" ou bien de "x" à "a" : (dans cet ordre "xa" ou celui-ci "ax" ?)

- Que faut-il indiquer si un protocole comporte plusieurs valeurs distinctes à savoir a, d, g, x : ("ax" ou "adgx" ou autres ?) Idem pour l'ordre ?

- Est-ce que votre fichier réel comporte bien uniquement des lettres et des x ou ce sont plutôt des mots ?

Aussi pas certain que le résultat soit celui voulu

Bonne soirée
MERCI ça Marche
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer validation matricielle
VB:
=SIERREUR(INDEX(B$2:B$17;PETITE.VALEUR(SI(($C$2:$C$17<>"x")*(NB.SI.ENS($B$2:$B$17;$B$2:$B$17;$C$2:$C$17;"x")=0);LIGNE($C$2:$C$17)-1);LIGNES($1:1)));"")
JHA
 

Fichiers joints

KTM

XLDnaute Occasionnel
Bonjour à tous,

A essayer validation matricielle
VB:
=SIERREUR(INDEX(B$2:B$17;PETITE.VALEUR(SI(($C$2:$C$17<>"x")*(NB.SI.ENS($B$2:$B$17;$B$2:$B$17;$C$2:$C$17;"x")=0);LIGNE($C$2:$C$17)-1);LIGNES($1:1)));"")
JHA
ok Merci
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas