Microsoft 365 Excel - Effacer les doublons (uniquement le contenu de la cellule)

soulwax

XLDnaute Nouveau
Bonjour à tous,

Je tourne en ronds depuis tout à l'heure pour qlq chose d'assez simple...

Je cherche à effacer mes doublons, cependant, l'outil suppression des doublons en excel supprime toute la ligne associé au doublon :(
Dans le cadre de l'utilisation de ce fichier (BDD), je souhaite réaliser la suppression des doublons directement depuis la colonne des valeurs en "B" à l'image de l'outil Excel mais sans supprimer la ligne entière. Dois-je passer absolument par une macro? Mon niveau y est médiocre

Voici un exemple en PJ de mon fichier.

Merci pour aide :)
 

Pièces jointes

  • Doublon.xlsx
    17 KB · Affichages: 9

Nairolf

XLDnaute Accro
Salut soulwax,

Tout dépend si tu veux modifier dans la même colonne ou si tu acceptes la création d'une colonne supplémentaire.

A mon sens, dans le premier cas il faut un code vba et dans le second cas, la formule suivante permet d'obtenir ce que tu souhaites (formule à mettre sur la ligne 2 et étirer vers le bas) :
Code:
=SI(NB.SI($B$2:B2;B2)>1;"";B2)
 

Nairolf

XLDnaute Accro
Salut,

Le code vba correspondant à la fonction donnée précédemment avec travail sur la plage d'origine :
VB:
Sub supdoublon()

nblignes = Application.WorksheetFunction.CountA(Range("B:B")) - 1

For i = 1 To nblignes
    If Application.WorksheetFunction.CountIf(Range("B1:B" & i), Range("B" & i)) > 1 Then
        Range("B" & i).ClearContents
    End If
Next i

End Sub
 

Discussions similaires

Haut Bas