Autres Excel 2007 copier coller different , tableau sur un autre tableau

jfcjfc

XLDnaute Nouveau
Re bonjour,
je revois ma copie
fichier joint pour plus d'explication.
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
Dim a, b, c, d, e, f As Integer
a = 1
b = 1
c = 14
d = 20
e = 3
f = 2
Sheets("Feuil1").Select
Range(Cells(a, b), Cells(c, d)).Copy
Sheets("Feuil2").Select
Cells(e, f).Select
SELECTION.PasteSpecial Paste:=xlValues, Operation:=xlNone, SkipBlanks:= _
False, Transpose:=False

Mais je souhaiterai que le "coller" se fasse sous la forme d'un autre tableau,
je précise que la longueur du tableau à copier peut varier.
Dans l'attente un grand merci !
cordialement
 

Pièces jointes

  • Copier_coller.xlsx
    15.6 KB · Affichages: 4

Phil69970

XLDnaute Accro
Bonjour @jfcjfc

Ouvrir un nouveau post toutes les 2 heures pour le même sujet ne peut être que contre productif et avoir l'effet inverse de l'effet désiré:mad:
*C'est le 4eme post aujourd'hui pour le même problème et le 3eme de puis 13h30 🤔 🤔

*Je te conseille de supprimé tous tes posts superflus (demande l'aide de @Yeahou le modérateur du forum de t'aider à déplacer/supprimer tes posts) et de concentrer sur un seul post ou tu expose ton problème avec les modification/précision que tu veux apporter.

*Cela fait quand même 5 ans que tu es inscrit sur le forum.....

@Phil69970
 

job75

XLDnaute Barbatruc
Bonjour à tous,

En plus jfcjfc est obnubilé par le VBA.

Dès la 1ère discussion j'avais proposé une solution par formule qui fonctionne très bien ici.

Dans le fichier joint voyez cette formule très simple sur la plage B3:BS16 de Feuil2 :
Code:
=SIERREUR(RECHERCHEH(COLONNE()-1;Feuil1!$A1:$T1;1;0);"")
A+
 

Pièces jointes

  • Copier_coller(1).xlsx
    21 KB · Affichages: 2

job75

XLDnaute Barbatruc
Si l'on veut du VBA on utilisera la même formule.

Voyez le fichier joint et cette macro dans le code de la feuille "Résultat" :
VB:
Private Sub Worksheet_Activate()
Dim dest As Range, nlig&, ncol%
Application.ScreenUpdating = False
Cells.Delete 'RAZ
Set dest = [B2] 'à adapter
With Sheets("Feuil1").[A1].CurrentRegion 'à adapter
    nlig = .Rows.Count
    ncol = Application.Max(.Cells)
    dest = 1: dest.Resize(, ncol).DataSeries 'numérotation
    dest(2).Resize(nlig, ncol) = "=IFERROR(HLOOKUP(COLUMN()-" & dest.Column - 1 & "," & .Rows(1).Address(0, 1, External:=True) & ",1,0),"""")"
    dest(2).Resize(nlig, ncol) = dest(2).Resize(nlig, ncol).Value 'supprime les formules, à mettre en commentaire pour les voir
End With
'---mise en forme---
With dest.Resize(nlig + 1, ncol)
    Range("A1", .Cells).ColumnWidth = 2.5
    .HorizontalAlignment = xlCenter
    .Borders.Weight = xlThin 'bordures
    .Rows(1).Interior.ColorIndex = 6 'jaune
End With
End Sub
Elle se déclenche quand on active la feuille.

A+
 

Pièces jointes

  • Copier_coller VBA(1).xlsm
    21.6 KB · Affichages: 1

Discussions similaires

Réponses
2
Affichages
246

Membres actuellement en ligne

Statistiques des forums

Discussions
293 048
Messages
1 928 126
Membres
183 855
dernier inscrit
safelhr