€ se transforme en F

P

petchy

Guest
Bonsoir le Forum,
une petite question,j'ai des cellules avec des sommes en Euros est il possible,quand on passe sur la celleule le somme en € se transforme en F comme si on avait inséré un commentaire.
j'espere avoir était assez clair.

 
V

vincent

Guest
As-tu vérifié que le format de la cellule "somme" était dans la bonne devise. Par défaut tu as sûrement "en francs" (ton clavier te donne l'€ par un CTRL E?)
 
P

petchy

Guest
Re bonsoir le forum
merci Vincent,mais je crois que je me suis mal expliqué:
en fait les cellules sont dans le bon format,j'ai fait un prog pour mon compte bancaire à l'aide des personnes de se forum.J'explique je rentre les sommes en € ,se que je voudrais si c'est possible, c'est quand je passe avec la souris sur une cellule qui à une somme en €,c'est de voir apparaitre un petit rectangle avec la meme somme mais en FRANC,et quand je ne suis plus devant la celleule le petit rectangle disparait.

Est ce possible ?
merci
petchy
 
J

Johan

Guest
Salut Petchy,
avec un commentaire j'y arrive, regarde avec le code ci-dessous

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
Set cmt = ActiveSheet.Comments
Dim valCell As Currency

For Each c In cmt
c.Delete
Next

If Target.Value = "" Then

Else
valCell = Target.Value * 6.6
With Target.AddComment
.Text valCell & " Euro"
.Shape.Height = 15
.Shape.Width = 100
End With
End If
End Sub


Johan
 
P

petchy

Guest
salut le forum

Merci Johan,ou dois je mettre se code,j'ai essayé dans un nouveau module mais rien ne se passe ?

@ plus
petchy
 
J

Johan

Guest
Rebonjour Petchy,

à mettre dans la feuille où se trouvent tes données (p. ex Feuil1)

en haut du VB editeur de cette feuille se trouvent 2 combobox où tu peux choisir dans le premier 'Worksheet' et dans la 2ième 'SelectionChange'

De cette façon il t'écrit automatiquement la ligne 'Sub ....'

Et rajoute peut-être aussi On Error Resume Next dans ton code, pourqu'il te donne pas de message d'erreur quand tu sélectionnes p. ex. plusieurs cellulles à la fois.

Bon VBisme,

Johan
 
J

Johan

Guest
Petchy,

tu as sûrement l'Option Explicit (qui est au fait une bonne chose).
rajoute dim cmt alors, ou enlève l'Option Explicit

Bonne chance, et si ça marche toujours pas, fait moi signe ... je t'enverrai l'exemple (se trouve au boulot!)

Johan
 
P

petchy

Guest
Re Re

MERCI MERCI,Johan ça fonctionne j'ai du enlevé l'Option Explicit ,car avec DIM rien à faire.
c'est sympa de m'avoir donné un coup de main.
bonne soirée
@ plus
petchy
 

Discussions similaires


Haut Bas