XL 2016 erreur cherchev

Seddiki_adz

XLDnaute Occasionnel
Bonjour
qui peut rectifier l'erreur en colonne F feuil1
Merci
 

Pièces jointes

  • doublant1414.xlsx
    114 KB · Affichages: 4
Solution
Bonne nuit à toutes & à tous, bonne nuit @Seddiki_adz
Il est vrai que tes posts sont plutôt sibyllins et que tu ne donne pas l'impression de chercher longtemps pour trouver ta solution.
Bon assez de morale et passons à la suite ;
Avec ce que j'ai compris,
  • J'ai transformé ton tableau nommé tableau1 de la feuil3 en tableau structuré (6 colonnes)
  • J'ai élargi ton tableau structuré de la feuil1 à 6 colonnes
  • J'ai repris la formule de la colonne "nombre d hand" du tableau 1 :
    VB:
    =NB.SI.ENS([code];[code])   => version EXCEL 2007
    =NB.SI.ENS([code];[@code])  => version EXCEL 365 ou 2021
    cela compte le nombre d’occurrences d'un code dans le tableau
  • J'ai écrit la formule suivante dans la colonne "nombre d hand"...

soan

XLDnaute Barbatruc
Bonsoir Seddiki,

qui peut rectifier l'erreur

peut-être toi ? et si tu essayais un peu toi-même ? ça te fera progresser un peu si tu y arrives tout seul ! de toutes façons, ce serait mieux que tu décrives de quelle erreur il s'agit, au lieu d'indiquer seulement où elle se produit ; c'est peut-être noté dans ton fichier, mais vu qu'entre "Bonjour" et "Merci" tu n'écris qu'une seule phrase de quelques mots, je n'ai pas pris la peine de télécharger ton fichier ; ce défaut récurrent est particulièrement flagrant ici :​

Image.jpg


écrire un post d'un seul mot, avoue que tu as fait fort ! 😁



edit : j'ai zappé que la nature de l'erreur est indiquée dans le titre, sauf que la fonction Excel n'est pas cherchev, c'est : RECHERCHEV() ; dans ce cas, je vais quand même télécharger ton fichier, et voir si je trouve une solution à proposer. (c'est sans garantie)

soan
 

soan

XLDnaute Barbatruc
Re,

J'ai téléchargé ton fichier ; à l'ouverture, j'ai eu ce message :

Image.jpg


j'ai quand même pu aller sur ton fichier ; sur "Feuil1", ta formule en F7 est : =RECHERCHEV(A7;Tableau1;5)

il manque le dernier argument "valeur proche" ; et A7 fait partie de Tableau1, d'où référence circulaire !

je n'aime pas corriger des références circulaires, alors je passe la main ! 😁

soan
 

Seddiki_adz

XLDnaute Occasionnel
Re,

J'ai téléchargé ton fichier ; à l'ouverture, j'ai eu ce message :

Regarde la pièce jointe 1139519

j'ai quand même pu aller sur ton fichier ; sur "Feuil1", ta formule en =RECF7 est : HERCHEV(A7;Tableau1;5)

il manque le dernier argument "valeur proche" ; et A7 fait partie de Tableau1, d'où référence circulaire !

je n'aime pas corriger des références circulaires, alors je passe la main ! 😁

soan
= REHERCHEV(A7;Tableau1;5.0)
 

Pièces jointes

  • doublant1414.xlsx
    108.7 KB · Affichages: 1

soan

XLDnaute Barbatruc
= REHERCHEV(A7;Tableau1;5.0)

ah bon ? tu utilises le point comme séparateur d'argument, maintenant ? tu ne risques pas d'aller bien loin, avec ça ! le séparateur d'argument doit être un point-virgule (du moins pour les versions françaises d'Excel ; c'est la virgule pour les versions anglaises) ; donc pour un Excel français, ça donne : =RECHERCHEV(A7;Tableau1;5;0)

et surtout, note bien que la fonction REHERCHEV() n'existe pas : c'est RECHERCHEV() ! tu pourrais faire l'effort de taper sans oublier de lettres, ou au moins de te relire pour vérifier ce que tu écris ; d'autant plus que comme tu n'écris que des phrases courtes, comme d'habitude, ça ne risque certainement pas de te prendre beaucoup de temps !

pour les références circulaires, je te laisse te débrouiller ; un autre contributeur passera peut-être t'aider ?​

soan
 

Seddiki_adz

XLDnaute Occasionnel
Merc
ah bon ? tu utilises le point comme séparateur d'argument, maintenant ? tu ne risques pas d'aller bien loin, avec ça ! le séparateur d'argument doit être un point-virgule (du moins pour les versions françaises d'Excel ; c'est la virgule pour les versions anglaises) ; donc pour un Excel français, ça donne : =RECHERCHEV(A7;Tableau1;5;0)

et surtout, note bien que la fonction REHERCHEV() n'existe pas : c'est RECHERCHEV() ! tu pourrais faire l'effort de taper sans oublier de lettres, ou au moins de te relire pour vérifier ce que tu écris ; d'autant plus que comme tu n'écris que des phrases courtes, comme d'habitude, ça ne risque certainement pas de te prendre beaucoup de temps !

pour les références circulaires, je te laisse te débrouiller ; un autre contributeur passera peut-être t'aider ?​

soan
Merci
 

AtTheOne

XLDnaute Occasionnel
Bonne nuit à toutes & à tous, bonne nuit @Seddiki_adz
Il est vrai que tes posts sont plutôt sibyllins et que tu ne donne pas l'impression de chercher longtemps pour trouver ta solution.
Bon assez de morale et passons à la suite ;
Avec ce que j'ai compris,
  • J'ai transformé ton tableau nommé tableau1 de la feuil3 en tableau structuré (6 colonnes)
  • J'ai élargi ton tableau structuré de la feuil1 à 6 colonnes
  • J'ai repris la formule de la colonne "nombre d hand" du tableau 1 :
    VB:
    =NB.SI.ENS([code];[code])   => version EXCEL 2007
    =NB.SI.ENS([code];[@code])  => version EXCEL 365 ou 2021
    cela compte le nombre d’occurrences d'un code dans le tableau
  • J'ai écrit la formule suivante dans la colonne "nombre d hand" du Tableau2 (feuil1)
  • Code:
    =SIERREUR(RECHERCHEV([code];Tableau1;6;FAUX);"?")    => version EXCEL 2007
    =SIERREUR(RECHERCHEV([@code];Tableau1;6;FAUX);"?")   => version EXCEL 365 ou 2021
    cela te ramène dans le tableau 1 le résultat de la colonne "nombre d hand" du tableau1 dans le tableau2 ou affiche un point d'interrogation si le code n'est pas trouvé.
Merci de me faire un retour un peu plus long qu'un simple merci ;)
Amicalement
Alain
 

Pièces jointes

  • doublant1414.xlsx
    110.9 KB · Affichages: 3

soan

XLDnaute Barbatruc
Bonjour Alain,

Merci de me faire un retour un peu plus long qu'un simple merci ;)

Ben en fait, il n'y a pas eu de retour du tout ! 😁 (même pas le seul mot « merci » : 0 mot)

Mais Seddiki a quand même eu la gentillesse de passer ton post en résolu, et on est sûr que c'est lui puisque seul le demandeur peut passer un post en solution ; de mon côté, je te mets un Like pour te remercier de la peine que tu t'es donné pour lui trouver une solution.

(et malgré ses références circulaires, en plus ! 😉)

soan
 

Seddiki_adz

XLDnaute Occasionnel
Bonjour Alain,



Ben en fait, il n'y a pas eu de retour du tout ! 😁 (même pas le seul mot « merci » : 0 mot)

Mais Seddiki a quand même eu la gentillesse de passer ton post en résolu, et on est sûr que c'est lui puisque seul le demandeur peut passer un post en solution ; de mon côté, je te mets un Like pour te remercier de la peine que tu t'es donné pour lui trouver une solution.

(et malgré ses références circulaires, en plus ! 😉)

soan
Merci
 

Phil69970

XLDnaute Barbatruc
Bonjour à tous

Perso j'ai vu que @Seddiki_adz ne fait aucun effort d'explication dans ces demandes et aucun effort de comprendre un minimum les codes proposés (même les plus simples) par les différents intervenants.

Il multiplie les posts identiques quand il n'a pas de réponse et de plus bien souvent il faut jouer les "Champollion" pour déchiffrer ces demandes et insister pour avoir une réponse qui bien souvent tiens en un mot voire n'est que la copie de la réponse posée.

Avec ce genre de comportement il ne fait que lasser la majorité des gens qui essaye de l'aider.
De plus plusieurs personnes lui ont fait les mêmes remarques sans aucun changement j'en conclu qu’il se moque complètement de nous.

Je prends le pari que sa réponse sera la copie de mon intervention suivi de moins de 3 mots.....o_O

@Phil69970
 

Seddiki_adz

XLDnaute Occasionnel
Bonjour à tous

Perso j'ai vu que @Seddiki_adz ne fait aucun effort d'explication dans ces demandes et aucun effort de comprendre un minimum les codes proposés (même les plus simples) par les différents intervenants.

Il multiplie les posts identiques quand il n'a pas de réponse et de plus bien souvent il faut jouer les "Champollion" pour déchiffrer ces demandes et insister pour avoir une réponse qui bien souvent tiens en un mot voire n'est que la copie de la réponse posée.

Avec ce genre de comportement il ne fait que lasser la majorité des gens qui essaye de l'aider.
De plus plusieurs personnes lui ont fait les mêmes remarques sans aucun changement j'en conclu qu’il se moque complètement de nous.

Je prends le pari que sa réponse sera la copie de mon intervention suivi de moins de 3 mots.....o_O

@Phil69970
Merci
 

soan

XLDnaute Barbatruc
Bonjour Efgé, le fil,

Peut-être @seddiki n'est il pas francophone....

en fait, on est sûr qu'il n'est pas francophone ; il semblerait que sa langue maternelle soit l'arabe ; soit ; mais dans ce cas, à sa place : j'utiliserai google translate arabe - français ; à gauche, j'écris ma demande ou mes réponses en arabe, même si le texte est un peu long ; à droite, j'ai la traduction en français ; et j'en fait un copier / coller dans le post du forum.

d'autre part, s'il a du mal à comprendre le français, alors comment fait-il pour comprendre les réponses en français qu'on lui apporte ? mystère ! s'il ne fait pas une traduction français - arabe avec google translate, je ne vois pas comment il peut y arriver !​

(ou un autre traducteur que google translate)

soan
 

Statistiques des forums

Discussions
297 848
Messages
1 963 743
Membres
200 185
dernier inscrit
mike54