XL 2010 Erreur 1004.

DAVID-44-

XLDnaute Occasionnel
Bonjour le forum,
J'ai un petit souci.
J'utilise un code pour colorer la cellule sélectionnée en rouge et ça fonctionne très bien.
Par contre, dès que j'utilise le bouton "Supprimer", j'ai une erreur "1004" et tout est bloqué.
Merci de votre aide.
Bon après-midi.
Cordialement.
David.
 

Pièces jointes

  • STOCK - 03 - 09 - 2021 - PROBLEME..xlsm
    220.2 KB · Affichages: 11

Dudu2

XLDnaute Barbatruc
Bonjour,
Cela semble arriver après une suppression de ligne.
Dans la suppression de ligne tu finis par protéger la feuille active.
Je ne crois pas que tu puisses modifier les FormatConditions si la feuille est protégée.
1630908971708.png
 

job75

XLDnaute Barbatruc
Bonjour DAVID-44-, Dudu2,

Oui, à l'ouverture du classeur la feuille STOCK est protégée ainsi :
VB:
.Protect Contents:=True, Password:="DAbaju042013@44@", UserInterfaceOnly:=True, AllowFormattingCells:=True
Il faut que ça serve à quelque chose !!!

Or dans la macro SupprimerLignesSélection vous annulez cet état en déprotégeant/protégeant la feuille.

Alors que c'est inutile et nuisible, donc corrigez cette macro.

A+
 

Dudu2

XLDnaute Barbatruc
Bonjour @job75,

En effet, la feuille STOCK est protégée à l'ouverture, il faut croire qu'il y a une raison.
Mais je dirais qu'elle est "bien" protégée compte tenu de ce qui est fait dans le Sub Worksheet_SelectionChange(), c'est à dire du FormatConditions.

C'est dans le Sub SupprimerLignesSélection() qu'elle est "mal" protégée, ne reprenant pas l'option AllowFormattingCells:=True.

D'ailleurs:
1 - Il n'y a pas de cohérence dans les .Protect qui tantôt utilise 2 options, tantôt 1 seule et tantôt aucune.
2 - La déprotection / protection ne tient pas compte de savoir si la feuille est initialement protégée ou pas.
3 - Dans le Sub SupprimerLignesSélection() c'est le chaos complet avec les .UnProtect et .Protect cités à différents endroits, avec un mot de passe tantôt en dur et tantôt en variable.
 

DAVID-44-

XLDnaute Occasionnel
Bonjour job75, Dudu2, le forum,
Je reviens vous demander de l'aide, je vais sur une ligne (ex : jambon) je clique droit, puis je clique sur "insérer produit" j'ai une erreur "400"!
Merci de votre aide.
Bonne journée.
Cordialement.
David.
 

Pièces jointes

  • STOCK - 03 - 09 - 2021 - PROBLEME(1).xlsm
    244.1 KB · Affichages: 4

Membres actuellement en ligne

Statistiques des forums

Discussions
291 667
Messages
1 916 971
Membres
179 500
dernier inscrit
oximo
Haut Bas