Erreur 1004 suite au lancement d'une macro TRI

GROOM83

XLDnaute Nouveau
Bonjour,

Bon cela fait plusieures heures que j'écume les forums sur mon cas... malheureusement chaque cas semble être un cas particulier... alors je vais vous exposer le mien.

J'ai créé dans un tableau "Bilans" des boutons de macro qui me permettent de trier de manière décroissante les données de 2 colonnes sur un seul champ de TRi. (macro effectuée sous excel 2003 qui fonctionne très bien...)

En revanche lorsque je change de poste et que je souhaite lancer ma macro (sous excel 2000) un message d'erreur apparait "erreur d'execution 1004" Erreur définie par l'application ou par l'objet... en cliquant donc sur débogage ma zone de code ci dessous apparait surlignée:

Selection.Sort Key1:=Range("EJ2"), Order1:=xlDescending, Header:=xlNo, _
OrderCustom:=1, MatchCase:=False, Orientation:=xlTopToBottom, _
DataOption1:=xlSortNormal


Aalors je ne sais pas si cela vient du code, du fait que je lance la macro sous une autre version d'excel...?? Voilà, en tt cas merci pour toute l'aide que vs pourrez m'apporter.

;)
 
G

Guest

Guest
Re : Erreur 1004 suite au lancement d'une macro TRI

Bonjour,

A tester:

Code:
[COLOR=black]Selection.Sort Key1:=Range("[COLOR=red][B]EJ1[/B][/COLOR]"), Order1:=xlDescending, Header:=xlNo, _
OrderCustom:=1, MatchCase:=False, Orientation:=xlTopToBottom, _
DataOption1:=xlSortNormal

[/COLOR]

Ou en enlevant DataOption1:=...


Code:
Selection.Sort Key1:=Range("EJ2"), Order1:=xlDescending, Header:=xlNo, _
OrderCustom:=1, MatchCase:=False, Orientation:=xlTopToBottom

Difficile de répondre mieux sans le tableau.

A+
 
Haut Bas