XL 2013 Enlever les 7 derniers caracteres sans passer par la fonction remplacer par

djc974

XLDnaute Nouveau
Bonjour,

j'essaie de trouver une formule qui supprime automatiquement les 7 derniers caractères de la cellule . cette formule doit etre appliqué à une colonne entiere et tous les jours je doit faire des extract
Je souhaiterai enlever " (prod) dans chaque cellule automatiquement sachant que certaines cellule ont pro et d'autre non
merci
ex:
69091GIV (prod)
CUV69 (prod)
73065ITA (prod)
42103LAG (prod)
STA38
STA38
69149OUL (prod)
69260VON (prod)
SAINT-ETIENNE
SAINT-ETIENNE
 

Staple1600

XLDnaute Barbatruc
Bonsoir le fil

Une autre façon de faire: Données/Convertir => Séparateur [x] Autre : (
Cliquer sur "Colonne non distribuée" pour la seconde colonne.

Ce qui donne en VBA (en cas de tendinite du poignet ;))
VB:
Sub Macro1()
Dim fo
fo = Array(Array(1, 1), Array(2, 9))
Columns(1).TextToColumns Cells(1), xlDelimited, , Other:=True, OtherChar:="(", FieldInfo:=fo
End Sub
 

djidji59430

XLDnaute Barbatruc
Bonjour à tous,

=SIERREUR(GAUCHE(G2;CHERCHE(" (";G2));G2)
car tu n'as pas essayé avec xxxxx (pro) comme demandé


Crdlmt
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas