XL 2016 Enlever automatiquement les colonnes vides d'un tableau

Xenopus

XLDnaute Nouveau
Bonjour à tous,

voici mon problème : à une étape d'un traitement de données automatisé j'abouti à un tableau dans lequel certaines colonnes du tableau sont vides.
Le nombre et la position des colonnes vides varient à chaque jeux de données traitée, voici un fichier avec un exemple.
Je cherche une solution pour obtenir automatiquement une nouvelle version du tableau sans les colonnes vides pour continuer l'analyse automatisée.
J'aimerai éviter de recourir à des filtres ou à des macro, une solution à base de formule serait l'idéal pour pour l'intégration de cette étape à l'ensemble du traitement que je fais.

Un grand merci par avance !

Bien cordialement,
 

Fichiers joints

Roblochon

XLDnaute Accro
Bonjour,

En pièce jointe un résultat avec power query (inclus dans excel 2016 'données/nouvelle requêtte).

P.S. PowerQuery ou PQ travaille sur des tableaus structurés. C'est lui qui ajoute automatiquement les noms "Colonne 1" à "Colonne n" au tableau d'origine pour les colonnes dont l'étiquette est vide.

La requête sélectionne les colonnes dont le nom ne commence pas par "Colonne" (sensible à la casse)

Cordialement
 

Fichiers joints

Dernière édition:

job75

XLDnaute Barbatruc
Bonjour Xenopus, Roblochon,

Voyez le fichier joint avec :

- formule matricielle en B27 à valider par Ctrl+Maj+Entrée et recopier sur C27:AG27 :
Code:
=SIERREUR(INDEX(3:3;PETITE.VALEUR(SI($B3:$AG3<>"";COLONNE($B3:$AG3));COLONNE()-1));"")
- formule en B28 à recopier sur B28:AG47 :
Code:
=INDEX($B4:$AG4;EQUIV(B$27;$B$3:$AG$3;0))
- la MFC sur B27:AG27 pour colorer les cellules <> "".

A+
 

Fichiers joints

Xenopus

XLDnaute Nouveau
Bonjour Job75 et Roblochon,

Les deux approches fonctionnent, merci beaucoup à tous les deux !

Bien cordialement
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas