XL 2010 Difficultés rencontrées sur un fichier

andros09

XLDnaute Nouveau
Bonjour à tous,

Je viens vers vous car je rencontre une difficulté pour obtenir un résultat automatique.
Je recherche à obtenir le numéro de rang d'un devis à l’intérieur d'une affaire ayant la même référence.
Par exemple
N° Affaire n° devis ordre du devis dans l'affaire (résultat recherche)
xx 100 1
xx 200 2
xy 200 2
xy 100 1
yx 300 3
yx 200 2
yx 100 1

Actuellement pour obtenir le résultat, je reclasse les lignes dans l'ordre et je fais une condition sur la référence affaire mais je cherche à rendre automatique ce traitement.
Est ce possible par des fonctions de EXCEL?
 
Dernière édition:

andros09

XLDnaute Nouveau
Mon message n'est pas comme je l'ai rédigé,
pour la premiere ligne
xx est le numero d'affaire
100 est le numero de devis
1 est l'ordre du devis dans l'affaire (résultat que je recherche à avoir automatiquement)
 

eriiiic

XLDnaute Barbatruc
Bonjour,

si j'ai bien compris :
Code:
=RANG(B2;DECALER($B$1; EQUIV(A2;A:A;0)-1;;NB.SI(A:A;A2););1)
Ta liste doit quand même être triée par N° Affaire (groupés plus exactement)
eric
 

andros09

XLDnaute Nouveau
bonjour,
Merci pour votre réponse.
En effet, je n'avais pas précisé que les affaires étaient triées par numéro d'affaire, initialement dans mon fichier ce n'était pas le cas mais j'ai fait en sorte que ce soit à présent toujours le cas.
 

andros09

XLDnaute Nouveau
J'aurai une autre question. Sur mon fichier j'utilise la formule :
=SOMME(NB.SI.ENS('detail devis'!U:U;SI(C4="toutes";{"2016";"2017";"2018";"2019";"2020"};'My report'!$C$4);'detail devis'!T:T;'My report'!$D$4;'detail devis'!J:J;"=1er devis"))

Cette formule fonctionne bien mais je veux utiliser une condition dans cette formule prévoyant que si je choisis dans la cellule C4 "Toutes" alors je veux toutes les années et je n'ai pas trouvé d'autres solutions que de ressaisir la liste des années dans ma formule.
Est ce qu'il y a une autre solution que de ressaisir toutes les années? j'ai essayé * mais ça ne fonctionne pas.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas