XL 2016 Différence de jour entre deux dates sur une période précise

Euljiro75fr

XLDnaute Nouveau
onjour à tous,

après de nombreuse recherche sur des forums je me permet de poser mon problème jusqu’à maintenant non résolu.

Je cherche à calculer le nombre de jour entre une “start date” et une “departure date” dans un mois précis de l’année 2019. (nombres sous les mois ci-dessous)

voici le l’exemple :
start date......departure-date .......Janvier 2019 ....Fevrier 2019 .........Mars 2019
01/01/1990 ...15/02/2019… .............30…..................15….............................0
15/01/2019.... 31/122019…................15..................…30…............................30
10/02/2019 ....20/03/2019….............0…...................20…...........................20

Existe-t-il un autre moyen que les fonctions Si imbriqué tel qu’en SQL utilisant WHERE(year=2019 AND month=1)?

merci pour votre lecture,
 

Fichiers joints

Chris401

XLDnaute Accro
Bonjour

Un essai :
Code:
=SOMMEPROD(N(MOIS(LIGNE(INDIRECT(MAX(DATE($C$3;1;1);$A5)&":"&SI($B5="";AUJOURDHUI();$B5))))=MOIS(1&C$4)))
Attention à l'écriture du mois (exemple Février)
 

Discussions similaires


Haut Bas