Des références pour les professionnels

PFG60

XLDnaute Junior
Bonjour à tous,

Je vous propose un petit fichier qui va vous permettre d'obtenir des références de documents.

En effet, les entreprises qui utilisent Excel avec des modèles enregistrent bien souvent le travail en format PDF afin de conserver une trace non modifiable (devis, factures...).
Dans cette optique, le fichier joint correspond à cette demande.

Comment savoir quand et à quelle heure a été créé et enregistré le document tout en ayant une seule et unique référence ?
Avec cette formule : =CONCATENER(TEXTE($A$1;"aammjj");"-EXE-";TEXTE(TEMPS(heure;minute;seconde);"hhmmss"))

Alors vous allez me dire : "Ok ! Mais c'est trop simple."
Pas du tout !

Ainsi le résultat sera unique : 140907-INF-110406.
La première série de chiffre correspond à :

  • 14 = année
  • 09 = mois
  • 07 = jour

Et la seconde à :

  • 11 = heure
  • 04 = minutes
  • 06 = secondes

"Très bien. Mais le texte au milieu ?"
C'est une abréviation de trois lettre pour vous repérez dans le type de document.
Dans le fichier joint, j'ai intégré des exemples.


Maintenant, c'est à vous d'intégrer cette méthode (comme une autre) dans vos fichiers vous servant de modèles.


PS : fonctionne correctement à partir d'Excel 2007
 

Fichiers joints

JCGL

XLDnaute Barbatruc
Re : Des références pour les professionnels

Bonjour à tous,

Merci pour ton partage.

Quitte à nommer des cellules autant ne pas les avoir en feuille :
=TEXTE(J;"aammjj")&"-EXE-"&TEXTE(TEMPS(H;M;S);"hhmmss"))
Et dans le Gestionnaire de Noms :

Capture 1.png

A+ à tous
 

Fichiers joints

PFG60

XLDnaute Junior
Re : Des références pour les professionnels

Ce n'est pas bête du tout.
Je vais corriger cela et mettre le nouveau fichier en ligne.


MAJ 07/09/14 16h26
ajout du fichier corrigé
 

Fichiers joints

Dernière édition:

R@chid

XLDnaute Barbatruc
Re : Des références pour les professionnels

Bonjour @ tous,
Code:
=TEXTE(AUJOURDHUI();"aammjj")&"-DEV-"&TEXTE(MAINTENANT();"hhmmss")
Mais il faut faire attention, puisque les 2 fonctions AUJOURDHUI() et MAINTENANT() sont volatiles, ceci-dit que si je ré-ouvre le fichier ou je le réactualise cette référence va changer, sinon, vaut mieux de le faire par une macro pour éviter cette problématique.

Edit : :p
Plus courte :
Code:
="DEV"&TEXTE(MAINTENANT();"-aammjj-hhmmss")

@ + +
 
Dernière édition:

PFG60

XLDnaute Junior
Re : Des références pour les professionnels

Bonjour R@chid,

Oui ta remarque est tout à fait justifiée.
Mais j'avais bien précisé :
En effet, les entreprises qui utilisent Excel avec des modèles enregistrent bien souvent le travail en format PDF afin de conserver une trace non modifiable (devis, factures...).
Le fichier que j'ai mis à disposition répond uniquement à ce besoin.

Je te rassure, pour les autres cas, une macro est effectivement bien plus adaptée.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas