Dernière valeur d'une colonne si..

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer cette formule matricielle pour 2017:
Code:
=INDEX($B$1:$B$50;MAX(SI(($A$1:$A$50=2017)*($B$1:$B$50);LIGNE($A$1:$A$50))))
A valider par Ctrl+Maj+Entrée

JHA
 

job75

XLDnaute Barbatruc
Bonsoir frank1974, JHA,

Si comme sur l'exemple le tableau est trié sur la colonne A :
Code:
=RECHERCHE(9^9;DECALER(B1;EQUIV(2017;A:A;0)-1;;NB.SI(A:A;2017)))
Pas besoin de validation matricielle et c'est bien plus rapide sur un grand tableau.

A+
 

frank1974

XLDnaute Nouveau
Merci à vous deux,

J'aime bien la formule suivante: =RECHERCHE(9^9;DECALER(B1;EQUIV(2017;A:A;0)-1;;NB.SI(A:A;2017)))

Y a-t-il un moyen d'utiliser la même genre de formule lorsqu'il y a une formule dans la colonne "A" (là ou il y a les années)?

MERCI :)
 

Chris401

XLDnaute Accro
Bonjour

Y a-t-il un moyen d'utiliser la même genre de formule lorsqu'il y a une formule dans la colonne "A" (là ou il y a les années)?
Si la formule renvoie 2017, cela ne change rien.
Autre formule si la colonne B est bien une série de chiffres allant de 1 à x telle que dans ton exemple :

Code:
=SOMMEPROD((A1:A26=2017)*(B1:B26>0))
Edit : après réflexion, peut-être que ta formule renvoie du texte ; si c'est le cas, dans la formule tu écris "2017" (avec les guillemets)
 
Dernière édition:

frank1974

XLDnaute Nouveau
Merci à vous tous,

Effectivement, j'avais seulement besoin d'ajouter " " à la formule suivante:

=RECHERCHE(9^9;DECALER(B1;EQUIV("2017";A:A;0)-1;;NB.SI(A:A;"2017")))
 

Discussions similaires


Haut Bas