XL 2016 Demande d'aide sur formule de planning

patsyl60

XLDnaute Occasionnel
Bonjour à tous,

Afin de connaître le nombre de personnes présentes par plage de 30 minutes, je n'arrive pas à trouver la formule adéquate. Pouvez vous m'aider. Je vous joint un petit fichier avec 3 exemples d'horaires mais dans la vraie vie, je peux monter à 20. Je vous ai fait manuellement le résultat final que je devrais avoir mais je souhaiterai le faire de manière automatique afin qu'à chaque changement ( congés , maladie, etc.) cela se mette à jour.
J'espère avoir été clair et dans ma demande et dans mon fichier exemple.
D'avance je vous remercie de votre aide.
Bonne journée à tous.
Patsyl60
 

Fichiers joints

Yeahou

XLDnaute Impliqué
Bonjour le forum, patsyl60, mapomme

et voila une formule à mettre en C9 et à tirer vers le bas

Cordialement

=SOMMEPROD(($D$2:$D$4>=A9)*($C$2:$C$4<B9))-SOMMEPROD(($D$2:$D$4>=A9)*($C$2:$C$4<B9)*($D$2:$D$4<B9))+SOMMEPROD(($F$2:$F$4>=A9)*($E$2:$E$4<B9))-SOMMEPROD(($F$2:$F$4>=A9)*($E$2:$E$4<B9)*($F$2:$F$4<B9))
 

Yeahou

XLDnaute Impliqué
re
la même simplifiée
=SOMMEPROD(($D$2:$D$4>=A9)*($C$2:$C$4<B9)*($D$2:$D$4>=B9))+SOMMEPROD(($F$2:$F$4>=A9)*($E$2:$E$4<B9)*($F$2:$F$4>=B9))
 

patsyl60

XLDnaute Occasionnel
Merci mapomme, Merci Yeahou.

2 jours que je galère et en moins d'une heure vous me trouvez la solution. Bravo !
Les 2 méthodes fonctionnent . Je vais voir laquelle des deux s'intègre le mieux dans mon projet.
Encore merci !
Bonne soirée.
Patsyl60
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas