XL 2016 Décalage résultats au changement de mois

Yoyo01000

XLDnaute Occasionnel
Bonjour, me revoilà
:mrgreen:


Je bloque sur un calcul de dates, sur les mois. Dans l'onglet "SUIVI", il me faut les valeurs du mois en cours, du mois -1, du mois -2, du mois -3.

Je pensais avoir trouvé la bonne formule mais non puisqu'elle ne serait plus valable dès le mois prochain.

J'a tenté diverses formules mais impossible de trouver ce que je veux obtenir
:cry:


Il faut que ces valeurs, bien sûr, se décalent d'une colonne à gauche dès qu'on passe au mois d'après.

Je laisse tomber pour le moment car il me reste guère de cheveux
:lol:
 
Dernière édition:

Yoyo01000

XLDnaute Occasionnel
Désolé si je n'ai pas été assez clair.

Dans l'onglet "SUIVI" et dans les colonnes où sont M-3 ; M-2 ; M-1 et M, je veux afficher les résultats des onglets "TL1" et "TL2".
Pour ces résultats, pas de problème, j'ai les formules.

Ce que je ne trouve pas, c'est avoir les valeurs du mois en cours (M) et arriver à faire la soustraction du mois en cours avec le mois -1 (M-1) ; le mois -2 (M-2) ; le mois -3 (M-3).

Et dès que le mois change, que les données de M se déplacent dans M-1, que les données de M-1 se déplacent dans M-2, etc

J'espère avoir apporté plus de clarté :)
 

Yoyo01000

XLDnaute Occasionnel
J'ai laissé "traîner" cette mauvaise formule, désolé !

La formule de calcul en B3 est, pour le mois de janvier de "TL1" :
=SI(NB.SI('TL1'!$C$97:$C$117;"X")>0;"O";"N")

Il me manque un bout de formule à intégrer pour que ce résultat se retrouve dans la colonne M-2.

J'espère que cette fois, je suis vraiment compréhensible :)
 

Yoyo01000

XLDnaute Occasionnel
J'ai essayé qq chose en B3-C3-D3-E3 mais ça ne va pas encore, je deviens fou !!!

J'espère que ça peut être source de compréhension, par la même occasion :)
 

Yoyo01000

XLDnaute Occasionnel
Ah oui, pardon, j'avais oublié de supprimer les noms sur un onglet (fatigue de fin de journée).

Merci de m'avoir prévenu :)

Je reposte le fichier, anonyme cette fois !
 

Fichiers joints

Discussions similaires


Haut Bas