1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

XL 2003 % de chiffres positifs par rapport aux chiffres négatifs

Discussion dans 'Forum Excel' démarrée par Jean-Patrick, 11 Janvier 2019 à 11:59.

  1. Jean-Patrick

    Jean-Patrick XLDnaute Nouveau

    Inscrit depuis le :
    Vendredi
    Messages :
    2
    "J'aime" reçus :
    0
    Bonjour,

    Je souhaiterai calculer en pourcentage le nombre de chiffres positifs par rapports au nombre de chiffres négatifs. Je ne sais pas si c'est très clair.
    J'ai dans un tableau Excel, des chiffres positifs (bonne chose) et des chiffres négatifs (mauvaise chose). Je voudrai calculer le pourcentage de chiffre dans les deux cas, peu importe le chiffre positif ou négatif. Ce qui m'intéresse c'est combien il y en a de négatif et combien il y en a de positif.

    J'ai essayé les formules suivantes:

    =NBVAL(SI(A1;A100;">0"))
    =NBVAL(SI(A1;A100;"<0"))

    Pour ensuite faire un pourcentage entre ces deux cellules, sans succès.

    Pouvez-vous m'aider?
     
  2. Chargement...

    Discussions similaires - chiffres positifs par Forum Date
    Limiter Textbox à 4 chiffres pour positifs que négatifs (- au debut uniquement) Forum Excel 29 Octobre 2013
    Affichage des chiffres positifs avec un "+" ou négatifs avec un "-" Forum Excel 19 Avril 2012
    Addition de chiffres négatifs avec des chiffres positifs Forum Excel 18 Juillet 2008
    extraire 1 ou 2 chiffres au format nombre [RESOLU] Forum Excel 6 Janvier 2019
    XL 2007 Séparer les chiffres dans un textbox Forum Excel 26 Décembre 2018

  3. Modeste geedee

    Modeste geedee XLDnaute Barbatruc

    Inscrit depuis le :
    8 Mars 2012
    Messages :
    6511
    "J'aime" reçus :
    797
    Sexe :
    Masculin
    Utilise:
    Excel 2007 (PC)
    =NB.SI(A1:A100;">0")/NB.SI(A1:A100;"<0")
     
    Dernière édition: 11 Janvier 2019 à 18:10
    Jean-Patrick aime votre message.
  4. Marjo2

    Marjo2 XLDnaute Junior

    Inscrit depuis le :
    4 Février 2016
    Messages :
    51
    "J'aime" reçus :
    3
    Sexe :
    Féminin
    Habite à:
    Nancy
    Utilise:
    Excel 2013 (PC)
    Nouveau
    Pour compter le nombre de cellule supérieur à 0 : NB.SI(A:A;">0")
    Pour compter le nombre de cellule inférieur à 0 : NB.SI(A:A;"<0")

    Pour avoir le nombre de cellule inférieur à 0 sur le total : NB.SI(A:A;"<0")/NBVAL(A:A)

    NB.SI = compte sous condition si
    NBVAL = compte le nombre de cellule non vide
     
    Jean-Patrick aime votre message.
  5. Jean-Patrick

    Jean-Patrick XLDnaute Nouveau

    Inscrit depuis le :
    Vendredi
    Messages :
    2
    "J'aime" reçus :
    0
    Merci pour vos réponses, les formules fonctionnent parfaitement!
     
  6. Marjo2

    Marjo2 XLDnaute Junior

    Inscrit depuis le :
    4 Février 2016
    Messages :
    51
    "J'aime" reçus :
    3
    Sexe :
    Féminin
    Habite à:
    Nancy
    Utilise:
    Excel 2013 (PC)
    Si vous êtes satisfait un petit "j'aime" svp
     
    Jean-Patrick aime votre message.

Partager cette page