XL 2019 Date future/mise en forme conditionnelle

zri123

XLDnaute Nouveau
Bonjour,
J'ai une colonne dans laquelle j'ai rentré une formule. Elle m'affiche des dates. Je cherche une fonction excel et le procédé pour que les cellules s'affichent automatiquement en couleur lorsque la date correspondante est dans 6 mois à compter d'aujourd'hui. J'ai essayé avec la mise en forme conditionnelle personnalisée mais ça ne fonctionne pas.
Merci pour votre aide
 

GALOUGALOU

XLDnaute Impliqué
re zri 123 bonjour djidji59430 bonjour le forum
une petite question
6 mois ?
vous sous entendez 6 mois calendaire, ou 6 mois en nombre de jours ~=180 jours.
de plus, la mfc s'applique uniquement pour la date dans 6 mois ou pour toute la période qui s'écoule de aujourd'hui à dans 6 mois ?
cordialement
galougalou
 

GALOUGALOU

XLDnaute Impliqué
re le fil salut JHA
les formules dans la mfc
pour uniquement dans 6 mois par rapport à aujourd'hui en colonne B
VB:
=SI(B1>AUJOURDHUI();SI(MOIS(B1)=MOIS(MOIS.DECALER(AUJOURDHUI();6));VRAI;FAUX))

pour de aujourd'hui à 6 mois en colonne E
Code:
=ET(E1<MOIS.DECALER(AUJOURDHUI();6);E1>AUJOURDHUI())
cordialement
galougalou
 

Pièces jointes

  • mfc forum.xlsx
    10.1 KB · Affichages: 5

verooo

XLDnaute Nouveau
Bonjour,

J'ai appliqué cette formule dans mon fichier excel en changeant le 6 pour un 2 car je veux les dates dans 2 mois. Toutefois, tous les mois de janvier sont apparus, même ceux en janvier 2027. Je voudrais que mes résultats se limitent à dans exactement 2 mois.

=SI(B1>AUJOURDHUI();SI(MOIS(B1)=MOIS(MOIS.DECALER(AUJOURDHUI();2));VRAI;FAUX))
 

verooo

XLDnaute Nouveau
L'ajout de $ ne change rien.

Voici en pièce jointe, un fichier très simplifié, avec lequel je travaille. Tu vois que le 5 janvier 2027 se met également en bleu, alors que j'aimerais que seulement les cellules représentants les échéances dans 2 mois apparaissent en bleu
 

Pièces jointes

  • Liste garanties.xlsx
    81.9 KB · Affichages: 5

verooo

XLDnaute Nouveau
On s'approche!!! Ça fonctionne, mais ca me sort tout ce qu'il y a entre aujourd'hui et les moins de 2 mois.
Moi je voudrais que ça mette en bleu seulement ceux qui viennent à échéance dans 2 mois. Juste ceux qui viennent à échéance en janvier 2021.

J'ai essayé ça, mais maintenant il n'y a plus aucun résultat...

=ET(AUJOURDHUI()<=$F6;AUJOURDHUI()=MOIS.DECALER($F6;-2))
 
Dernière édition:

Membres actuellement en ligne

Statistiques des forums

Discussions
289 676
Messages
1 902 006
Membres
173 307
dernier inscrit
takus
Haut Bas