XL 2019 DATE FORMULE EXCEL

aurel.ght

XLDnaute Nouveau
Bonjour à tous ,

J'ai un tableau de gestion documentaire avec :

- une colonne pour la date d'application
- une colonne pour l'actualisation 1
- une colonne pour l'actualisation 2
- une colonne pour l'actualisation 3


Cas n°1: Il n'y a pas d'actualisation sur le document , et donc il y a juste a ajouter 3 ans pour la date de révision donc le 01/01/2022
Date d'applicationActualisation 1 Actualisation 2 Actualisation 3Date de révision
01/01/201901/01/2022

Cas n°2: Il y a 3 actualisations sur le document , et donc il faut que la formule trouve la dernière actualisation entre les 3
Date d'applicationActualisation 1Actualisation 2Actualisation 3Date de révision
01/01/201915/01/201922/01/201923/01/201923/01/2022

Quelqu'un aurait une idéé d'une formule qui englobe les 2 cas pour que je puisse étirer cette formule dans toutes la colonne "date de révision"

Merci d'avance pour votre aide.

Je vous souhaite une bonne journée.
 

xUpsilon

XLDnaute Impliqué
Bonjour

=SI(Actualisation3<>"";Actualisation3; SI(Actualisation2<>"";Actualisation2;Si(Actualisation1<>"";Actualisation1; )
avec Actualisation1 la case de la date de la première actualisation, Actualisation2 la case de la date de la deuxième actualisation et Actualisation3 de la même manière.

Bonne continuation
 

pierrejean

XLDnaute Barbatruc
Bonjour
Il y a surement meilleur mais ceci doit fonctionner
=DATE(ANNEE(MAX(A1:D1))+3;MOIS(MAX(A1:D1));JOUR(MAX(A1:D1)))
 
Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas