XL 2016 Cumul semaine avec même numéro

JHA

XLDnaute Barbatruc
Bonjour à tous,

En "C14"
Code:
=SOMMEPROD((DROITE($F$2:$K$2;2)=$C$13)*(F3:K3))
Copier vers le bas

JHA
 

mcj1997

XLDnaute Impliqué
Bonjour,

Merci pour le retour, je souhaite adapter cette formule en l'adaptant dans un fichier qui va chercher l'information dans un autre avec la formule ci-dessous, s'agissant de fichiers professionnels je ne peux les mettre en ligne..

Dans le fichier ou j'ai la formule ci-dessous, je renseigne dans la cellule B4 le numéro de semaine souhaitée et la recherche se fait dans un autre fichier TOTAL, je cherche donc à adapter la formule sommeprod et droite dans la formule ci-dessous.

=INDEX('S:\TOTAL!$A$12:$EL$12;EQUIV("*"&$B$4;'S:\TOTAL'!$A$3:$EL$3;0))

Merci d'avance,
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Une autre sans droite()
Code:
=SOMMEPROD(($F$2:$K$2=$B$13&" "&$C$13)*($F3:$K3))
peut être
Code:
=SOMMEPROD(('S:\TOTAL!$A$3:$EL$3='S:\TOTAL!$B$3&" "&'S:\TOTAL!$B$4)*('S:\TOTAL!$A12:$EL12))
plages à adapter

JHA
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

une autre avec somme.si()
Code:
=SOMME.SI($F$2:$K$2;$B$13&" "&$C$13;$F3:$K3)
Pour index (equiv()), cela ne renverra que la première donnée soit "852" car cela n'est pas une somme mais une recherche de donnée.
Code:
INDEX($F3:$K3;EQUIV($B$13&" "&$C$13;$F$2:$K$2;0))
JHA
 

mcj1997

XLDnaute Impliqué
Bonjour

Je relance mon post 1 du 6 mars 2017 que je n’ai pas encore résolu et j’en aurai bien besoin.

Merci d’avance
 

chris

XLDnaute Barbatruc
Bonjour
Si tu veux avoir des chances de trouver une solution, il faudrait un exemple REPRESENTATIF de ton cas, les solutions données fonctionnant dans ton exemple mais pas dans ton fichier réel ....

Rien ne t’empêche d'anonymiser tes données ...
 

mcj1997

XLDnaute Impliqué
Effectivement les solutions données fonctionnent dans mon exemple, je souhaitais dans un premier temps trouver comment cumuler des semaines du même nom et ensuite l'adapter pour mon besoin.
Mon besoin en fait est d'aller chercher dans différents fichiers avec index (équiv( des valeurs pour les cumuler et lorsqu'il y a des semaines du même numéro l'addition ne se fait pas. J'ai donc besoin d'associer la solution qui m'est donnée ici avec index (équiv.
 

chris

XLDnaute Barbatruc
RE

Tu ne peux pas cumuler des INDEX/EQUIV. Comme déjà dit cela ne ramène qu'une valeur

D'où la nécessité de voir ce qu'on peut faire dans ton véritable cas...
 

gosselien

XLDnaute Barbatruc
Bonjour,

2 petites remarques ou questions
- pourquoi ne pas tout mettre dans un seul classeur ?
- pourquoi ne pas simplifier grandement des choses en mettant tes dates/jours/semaines dans une (ou des) colonnes(s) ?

P.
 

chris

XLDnaute Barbatruc
Bonjour à tous
Code:
=SOMMEPROD(('[fichier source.xlsx]Feuil1'!$B$3:$BB$3=$A$2)*1;'[fichier source.xlsx]Feuil1'!$B$6:$BB$6)
J'ai prévu 53 semaines mais si les semaines se répètent...
 

mcj1997

XLDnaute Impliqué
Bonjour,

Le problème est bien que des semaines se répètent, c'est un suivi d'ambitions qui se fait par semaine et par mois, par conséquent exemple la semaine 9 est sur février et sur mars.
 

mcj1997

XLDnaute Impliqué
Bonjour,

2 petites remarques ou questions
- pourquoi ne pas tout mettre dans un seul classeur ?
- pourquoi ne pas simplifier grandement des choses en mettant tes dates/jours/semaines dans une (ou des) colonnes(s) ?

P.
- 2 classeurs car un centralise des informations qui sont dans d'autres classeurs, sinon il n'y aurait pas de problème,
- pour simplifier je ne vois pas trop, je dois aller chercher dans les fichiers des productions de semaines et les cumuler.
 

chris

XLDnaute Barbatruc
Re
Bonjour,

Le problème est bien que des semaines se répètent, c'est un suivi d'ambitions qui se fait par semaine et par mois, par conséquent exemple la semaine 9 est sur février et sur mars.
Manifestement tu n'as pas testé la formule !

Je voulais juste dire que la plage utilisée à une largeur de 53 semaines mais rien ne t'empêche de la changer....

SOMME.SI.ENS marcherait aussi mais oblige à avoir le second classeur ouvert
 

mcj1997

XLDnaute Impliqué
Re


Manifestement tu n'as pas testé la formule !

Je voulais juste dire que la plage utilisée à une largeur de 53 semaines mais rien ne t'empêche de la changer....

SOMME.SI.ENS marcherait aussi mais oblige à avoir le second classeur ouvert
Ok merci, je viens de tester avec mes deux fichiers simplifiés joints et cela fonctionne, toutefois lorsque je mets la même formule dans mon fichier définitif j'ai le code erreur suivant : #REF!
Je viens de refaire x fois la même chose en recopiant bien la formule et c'est toujours pareil ?
 

chris

XLDnaute Barbatruc
RE

Il y a sans doute une différence entre ta version simplifiée et la réalité...
 

chris

XLDnaute Barbatruc
RE

en général REF se rapporte à une plage inexistante : donc bien vérifier nom du classeur, de la feuille et plages... chemin d'accès aussi si pas le même dossier
 

Discussions similaires


Haut Bas