XL 2013 Cumul de somme de matrice avec test logique

Alphacastor

XLDnaute Nouveau
Bonjour,


Pour récupérer des valeurs d'un tableau j'utilise en général une commande du genre :
[=SOMME(('02c'!H18:R18)*('02c'!H$4:R$4=C5)*('02c'!F18=B5)*('02c'!B18=A5))]

correspondant à :
(plage de valeur du tableau (ligne 18) ) * (le titre de la colonne du tableau correspond à C5) * ( le "N° de rapport" de la ligne 18 correspond à B5 ) * ( le "nom du bâtiment" de la ligne 18 correspond à A5)

(le tableau à un nombre de colonne variable)



La Question :
Y a t'il un moyen plus élégant d'avoir le total (dans une cellule) des résultats de cette commande sur 20 lignes différentes (non adjacentes) que de cumuler les = ... + ... + ... + ... ?
( et sans avoir de macro dans mon classeur)


Merci de vos contributions qui m'aide régulièrement. :)
 

Alphacastor

XLDnaute Nouveau
Oui, avec "Somme.si.ens" ça reviendrait aussi à empiler les couches (il me semble !?)

fichier test joint (des tableaux sans rapport direct ont été supprimés).
il s'agit de la colonne D de la feuille "02b"
 

Fichiers joints

Dugenou

XLDnaute Barbatruc
Supporter XLD
Bonjour,
en D6, à recopier vers le bas :
=SOMMEPROD(('02c'!$K$4:$N$4='02b'!C6)*('02c'!$F$8:$F$158='02b'!B6)*('02c'!$B$8:$B$158='02b'!A6)*'02c'!$K$8:$N$158)
Cordialement
 

Alphacastor

XLDnaute Nouveau
ah ... pfff ... oui ...
avec le contrôle sur la colonne F, je n'ai pas à m’embêter à sortir les lignes de sous-total je peux prendre la plage ... o_O
j'ai cherché trop loin.

MERCI ! Je testerai ça dès que j'ai un moment :)
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas