XL 2019 créer une liste clients pour mes factures et devis ...

stas

XLDnaute Nouveau
bonjour à tous, je viens de créer mon programme facture et devis.
le soucis c est que j'ai une liste clients et j' aimerais pouvoir utilisé une liste déroulante pour aller rechercher mes clients.
j y arrive mais quand je dois faire l'adresse et le code postal il me met des messages d'erreurs !!!!
une bonne âme pourrait elle m en dire plus svp
cordialement
stas ch
 

Roblochon

XLDnaute Impliqué
Bonjour,

une bonne âme pourrait elle m en dire plus svp
Je ne sais si elle sera bonne ou pas l'âme qui vous répondra, mais elle aura moins de difficultés à le faire si vous joigniez un fichier exemple anonymisé et sans données confidentielle, reproduisant exactement votre problème.

A vous relire
 

stas

XLDnaute Nouveau
merci je cherche pour vous envoyé mon programme excel je ne suis pas trop bon en la matière..
 

Roblochon

XLDnaute Impliqué
Re,

En bas de la fenêtre d'édition des message vous avez un bouton avec un trombone "Joindre des fichiers". Cliquez et laissez-vous guider.

A vous relire
 

Roblochon

XLDnaute Impliqué
Re bonjour,

Dans vos rechercheV vous devez mettre une la référence à votre tableau complet en deuxième argument et Faux en quatrième argument. (Voir dans le fichier V1 ci-dessous)

Dans le fichier V2, j'ai transformé votre tableau de client en tableau structuré au sens excel (voir l'excelent tuto : tableau structurés).
Ce tableau je l'ai nommé "T_Clients"

J'ai également créé un nom 'Liste_Clients' qui fait référence = T_Clients[nom] (colonne nom du tableau T_Client) ainsi votre liste se mettra à jour toute seule.

Petit conseil: évitez de mettre des lignes vides entre l'entête d'un tableau et ses données.

Cordialement
 

Fichiers joints

Victor21

XLDnaute Barbatruc
Supporter XLD
Bonjour, stas, Roblochon :)

=RECHERCHEV(E9;'liste cleints'!C3:C40;3)
Avec cette formule, vous recherchez la correspondance à la valeur dans E9 dans la 3° colonne de la zone c3:c40 (qui n'en contient qu'une) de la feuille "liste cleint".


=RECHERCHEV(E9;'liste cleints'!A3:C40;3)
Avec cette formule, vous recherchez la correspondance dans a3:a40 à la valeur dans e9 dans la 3° colonne de la zone a3:c40 de la feuille "liste cleint".
 

stas

XLDnaute Nouveau
re oui j'ai vu qu il y avait des menu déroulant dans la liste client maintenant,
mais quand je client dans mon devis ou facture, dans le nom il mélange tout adresse code postal de chaque client c'est cela mon problème !!
un tout grand merci pour votre bonne âme ;-)
cordialement
christophe
j ai beaucoup de mal avec excel c est déjà un exploit ce que j ai fait
click oupss
 

stas

XLDnaute Nouveau
je viens d'ajouter un client nom ok il est bon
prénom il reprend marc un contact plus haut dans la liste ....
je ne comprend pas très bien!!
merci d'avance pour votre aide
cordialement
christophe
 

Roblochon

XLDnaute Impliqué
Bonjour,

Dans le fichier ci-joint, la seule chose que j'ai changée dans vos formule, est l'ajout de FAUX en quatrième paramètre de la rechercheV.
J'ai changé et indexé les données (exemple: "Nom_1", "Rue_1") pour plus de facilité dans le repérage des erreurs éventuelles.
Peut-être devriez-vous conserver ce genre de données pendant la période de vos tests.

P.S. puisqu'il s'agit de devis et factures, la facture devrait reprendre les données clients (nom, prénom, coordonnées etc.) du devis. Non?
Par exemple la formule de 'facture sca'!E9' devrait être = 'devis sca'!E9'

Bon dimanche
 

Fichiers joints

stas

XLDnaute Nouveau
bonjour
merci pour votre aide je regarde à cela et vous souhaite une bonne fin de week end
cordialement
 

1_Robert

XLDnaute Nouveau
Bonjour Stas,
Dans le fichier V2 ammélioré de Roblochlon, la seule raison que le tout ne fonctionnait pas correctement à tous les coups, se résume à une erreur de base avec RECHERCHEV... la Table ou plage dans laquelle nous recherchons doit être triée (en utilisant la première colonne) et tout me semble maintenant OK (voir fichier V3 ci-inclus).
J'espère que mon grain de sel vous aidera et un jour ce sera à mon tour de vous solliciter.
Bonne fin de journée
Robert
 

Fichiers joints

Roblochon

XLDnaute Impliqué
Bonjour,

la Table ou plage dans laquelle nous recherchons doit être triée (en utilisant la première colonne) et tout me semble maintenant OK (voir fichier V3 ci-inclus).
Avec Faux en quatrième paramètre de rechercheV la Table n'a pas besoin d'être triée. Nous recherchons une correspondance exacte et non approximative.

Bonne journée
 

1_Robert

XLDnaute Nouveau
Bonjour à Tous,
Tu as raison Roblochon mais la version 2 à l'onglet "facture sca." en F9, la formule ne contenait pas l'argument FAUX et donc rapportait N/A à Grisard et Marc à SPRL ou à saint-Amand. Ta méthode avec FAUX est plus rapide que la mienne avec un TRI mais le résultat est celui attendu dans les deux cas alors tout est bien qui fini bien ;)
Bonne journée dans votre coin de pays,
Robert
 

Roblochon

XLDnaute Impliqué
Re,
Dans la réponse du post#6 :
Dans vos rechercheV vous devez mettre une référence à votre tableau complet en deuxième argument et Faux en quatrième argument. (Voir dans le fichier V1 ci-dessous)
Mais le demandeur n'ayant pas lu le post ou étudier la proposition... il n'a pas pu corrigé. Saura-t-il le faire la prochaine fois? Rien n'est moins sûr.

Bon après-midi
 

Discussions similaires


Haut Bas